aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Alexander Steffens (heftig)2015-06-25 21:21:17 +0200
committerJan Alexander Steffens (heftig)2015-06-25 21:21:17 +0200
commit5e65ebd5928c2f8b17e7a5176416250765afc747 (patch)
tree0e80bf7f9e0d66d3ab93122c3705771c9a21aab5
downloadaur-5e65ebd5928c2f8b17e7a5176416250765afc747.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD48
-rw-r--r--gpaste-git.install13
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d86f4bbea62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gpaste-git
+ pkgdesc = Clipboard management system with a GNOME Shell extension
+ pkgver = 3.16.2.1+11+g7b41300
+ pkgrel = 1
+ url = https://github.com/Keruspe/GPaste
+ install = gpaste-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = intltool
+ makedepends = vala
+ makedepends = appdata-tools
+ depends = gnome-shell
+ provides = gpaste=3.16.2.1+11+g7b41300
+ source = git://github.com/Keruspe/GPaste.git#branch=gpaste-3.16
+ md5sums = SKIP
+
+pkgname = gpaste-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65cd918b8ad0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: FzerorubigD <Fzerorubigd {AT} GMail {DOT} com>
+
+pkgname=gpaste-git
+pkgver=3.16.2.1+11+g7b41300
+pkgrel=1
+pkgdesc="Clipboard management system with a GNOME Shell extension"
+url="https://github.com/Keruspe/GPaste"
+arch=(i686 x86_64)
+license=(GPL3)
+depends=(gnome-shell)
+makedepends=(git intltool vala appdata-tools)
+install=gpaste-git.install
+provides=("gpaste=$pkgver")
+
+source=("git://github.com/Keruspe/GPaste.git#branch=gpaste-3.16")
+md5sums=('SKIP')
+
+pkgver() {
+ cd GPaste
+ git describe --long | sed 's/^v//;s/-/+/g'
+}
+
+prepare() {
+ cd GPaste
+ ./autogen.sh
+}
+
+build() {
+ cd GPaste
+ ./configure --prefix=/usr --libexecdir=/usr/lib --sysconfdir=/etc \
+ --enable-gnome-shell-extension --enable-systemd
+ make
+}
+
+check () {
+ cd GPaste
+ make -k check || :
+}
+
+package() {
+ cd GPaste
+ make DESTDIR="$pkgdir" install
+
+ cd data/completions
+ install -Dm644 gpaste "$pkgdir/usr/share/bash-completion/completions/gpaste"
+ install -Dm644 _gpaste "$pkgdir/usr/share/zsh/site-functions/_gpaste"
+}
diff --git a/gpaste-git.install b/gpaste-git.install
new file mode 100644
index 000000000000..7763bd19258b
--- /dev/null
+++ b/gpaste-git.install
@@ -0,0 +1,13 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -q -f -t /usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}