aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralbfan2016-12-06 07:59:40 +0100
committeralbfan2016-12-06 07:59:40 +0100
commitb4601eea62ddaa2eae430499b9fff22c7d54d5e5 (patch)
treeac4051357540933363b093317a39c026b02d340a
parente9a65bdfb7fc02ad49010b7795c54b45ab627dcb (diff)
downloadaur-b4601eea62ddaa2eae430499b9fff22c7d54d5e5.tar.gz
Stay on bleeding-edge
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
2 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0622d06258c3..875ffe9605b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,27 @@
# Generated by mksrcinfo v8
-# Sun Apr 17 11:27:04 UTC 2016
+# Tue Dec 6 06:56:56 UTC 2016
pkgbase = gpaste-git
pkgdesc = Clipboard management system
- pkgver = 3.20+3+g3503fca
+ pkgver = 3.22.1+23+g0923e96
pkgrel = 1
url = http://www.imagination-land.org/tags/GPaste.html
- install = gpaste.install
+ install = gpaste.install
arch = i686
arch = x86_64
license = GPL3
- makedepends = git
makedepends = intltool
makedepends = vala
makedepends = appstream-glib
makedepends = gobject-introspection
makedepends = gnome-shell
makedepends = gnome-control-center
+ makedepends = git
depends = gtk3
optdepends = wgetpaste: Upload clipboard contents
- provides = gpaste=3.20+3+g3503fca
+ provides = gpaste=3.22.1+23+g0923e96
conflicts = gpaste
options = !emptydirs
- source = git+https://github.com/Keruspe/GPaste#branch=gpaste-3.20
+ source = gpaste-git::git+https://github.com/keruspe/gpaste.git#branch=master
sha256sums = SKIP
pkgname = gpaste-git
diff --git a/PKGBUILD b/PKGBUILD
index fa71db57682e..73d4e4f82c96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,52 +2,52 @@
# Contributor: FzerorubigD <Fzerorubigd {AT} GMail {DOT} com>
pkgname=gpaste-git
-pkgver=3.20+3+g3503fca
+pkgver=3.22.1+23+g0923e96
pkgrel=1
pkgdesc="Clipboard management system"
url="http://www.imagination-land.org/tags/GPaste.html"
license=(GPL3)
arch=(i686 x86_64)
depends=(gtk3)
-makedepends=(git intltool vala appstream-glib gobject-introspection gnome-shell gnome-control-center)
+makedepends=(intltool vala appstream-glib gobject-introspection gnome-shell gnome-control-center git)
optdepends=("wgetpaste: Upload clipboard contents")
provides=("gpaste=$pkgver")
conflicts=(gpaste)
-options=('!emptydirs')
-install=gpaste.install
-source=("git+https://github.com/Keruspe/GPaste#branch=gpaste-3.20")
+options=(!emptydirs)
+source=("$pkgname::git+https://github.com/keruspe/gpaste.git#branch=master")
sha256sums=('SKIP')
pkgver() {
- cd GPaste
- git describe --long | sed 's/^v//;s/-/+/g'
+ cd $pkgname
+ git describe --tags | sed 's/^v//;s/-/+/g'
}
prepare() {
- cd GPaste
- ./autogen.sh
+ cd $pkgname
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd GPaste
- ./configure --prefix=/usr \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --enable-vala
+ cd $pkgname
+ ./configure --prefix=/usr --libexecdir=/usr/lib --sysconfdir=/etc \
+ --enable-vala --enable-applet
make
}
check () {
- cd GPaste
- make -k check || :
+ cd $pkgname
+ make check
}
package() {
- cd GPaste
+ cd $pkgname
make DESTDIR="$pkgdir" install
install -Dm644 data/completions/gpaste-client \
"$pkgdir/usr/share/bash-completion/completions/gpaste-client"
install -Dm644 data/completions/_gpaste-client \
"$pkgdir/usr/share/zsh/site-functions/_gpaste-client"
+
+ # Don't autostart the applet, ever
+ rm "$pkgdir/etc/xdg/autostart/org.gnome.GPaste.Applet.desktop"
}