summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhonjow2024-02-18 20:23:56 +0000
committerhonjow2024-02-18 20:23:56 +0000
commit765b3a946f5e92cc840369e76dde883a4619d046 (patch)
treec6d464daf64a53e9a742d37b0c4754f7e16ea2d1
downloadaur-765b3a946f5e92cc840369e76dde883a4619d046.tar.gz
Update AUR package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb1adfe1bae3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gpdconfig-git
+ pkgdesc = Configuration tool for GPD Win devices.
+ pkgver = r335.5816c96
+ pkgrel = 1
+ url = https://github.com/pelrun/pyWinControls.git
+ arch = x86_64
+ license = GPL3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python
+ depends = python-setuptools
+ source = git+https://github.com/pelrun/pyWinControls.git
+ sha512sums = SKIP
+
+pkgname = gpdconfig-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf11204122e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Antheas Kapenekakis <aur at antheas dot dev>
+pkgname=gpdconfig-git
+_repo=pyWinControls
+pkgver=r335.5816c96
+pkgrel=1
+pkgdesc="Configuration tool for GPD Win devices."
+arch=('x86_64')
+url='https://github.com/pelrun/pyWinControls.git'
+license=('GPL3')
+depends=('python' 'python-setuptools')
+makedepends=('python-'{'build','installer','setuptools','wheel'})
+source=("git+$url")
+sha512sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${_repo}"
+ python -m build --wheel --no-isolation
+}
+
+pkgver() {
+ cd "${srcdir}/${_repo}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_repo}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ mkdir -p ${pkgdir}/usr/lib/udev/rules.d/
+ install -m644 99-kb-hid.rules ${pkgdir}/usr/lib/udev/rules.d/99-kb-hid.rules
+}