summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBill Sun2018-02-08 22:37:50 -0500
committerBill Sun2018-02-08 22:41:23 -0500
commit900293ac4549db9c1eb127bb70ea219a85f00c0e (patch)
treeb981b15b2155923fb9bb8b1bbaddaf5ae6458285
downloadaur-900293ac4549db9c1eb127bb70ea219a85f00c0e.tar.gz
Initial commit---A working PKGBUILD.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa93e9769ba6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gpdfx-ng-git
+ pkgdesc = gpdfx-ng is a GTK application written in Python using the Poppler library to render the PDF.
+ pkgver = r22.c42ef90
+ pkgrel = 1
+ url = https://github.com/yishilin14/gpdfx-ng
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = python-gobject
+ depends = python-cairo
+ depends = poppler-glib
+ depends = texlive-core
+ source = git+https://github.com/yishilin14/gpdfx-ng
+ md5sums = SKIP
+
+pkgname = gpdfx-ng-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..413514cd0d24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Bill Sun <capsensitive at gmail dot com>
+
+pkgname=gpdfx-ng-git
+pkgver=r22.c42ef90
+pkgrel=1
+pkgdesc="gpdfx-ng is a GTK application written in Python using the Poppler library to render the PDF."
+arch=('any')
+url="https://github.com/yishilin14/gpdfx-ng"
+license=('GPL3')
+depends=("python" "python-gobject" "python-cairo" "poppler-glib" "texlive-core")
+makedepends=('git')
+source=('git+https://github.com/yishilin14/gpdfx-ng')
+noextract=()
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ # Git, tags available
+ #printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm 755 src/gpdfx-ng "$pkgdir"/usr/bin/gpdfx-ng
+}