summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2015-10-10 16:56:19 +0100
committermschubert2015-10-10 16:56:19 +0100
commit0531d062050565cb15b68fdda31c0ee25fe42eb0 (patch)
treefa003306648b9f8d27fbe1a27c8968ed167c775b
downloadaur-0531d062050565cb15b68fdda31c0ee25fe42eb0.tar.gz
initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD51
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f331859b0310
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = gperftools-git
+ pkgdesc = Fast, multi-threaded malloc and nifty performance analysis tools
+ pkgver = 2.4.r46.g6627f92
+ pkgrel = 1
+ url = http://code.google.com/p/gperftools/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = perl
+ optdepends = graphviz: pprof graph generation
+ optdepends = gv: pprof postscript generation
+ provides = libtcmalloc.so
+ provides = libprofiler.so
+ provides = libtcmalloc_debug.so
+ provides = libtcmalloc_and_profiler.so
+ provides = libtcmalloc_minimal.so
+ provides = libtcmalloc_minimal_debug.so
+ provides = gperftools
+ conflicts = gperftools
+ source = git+https://github.com/gperftools/gperftools.git
+ md5sums = SKIP
+
+pkgname = gperftools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35d5d078ccc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id: PKGBUILD 228975 2015-01-13 15:48:05Z dreisner $
+# Maintainer: Dave Reisner <dreisner@archlinux.org>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Thomas Jost <schnouki@schnouki.net>
+# Contributor: JaDa <jada@archlinux.us>
+# Contributor: Joaquim Pedro <osmano807@gmail.com>
+# Contributor: Jan Rüegg <rggjan@gmail.com>
+
+pkgname=gperftools-git
+_pkgname=gperftools
+pkgver=2.4.r46.g6627f92
+pkgrel=1
+pkgdesc="Fast, multi-threaded malloc and nifty performance analysis tools"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/gperftools/"
+license=('BSD')
+depends=('perl')
+provides=('libtcmalloc.so'
+ 'libprofiler.so'
+ 'libtcmalloc_debug.so'
+ 'libtcmalloc_and_profiler.so'
+ 'libtcmalloc_minimal.so'
+ 'libtcmalloc_minimal_debug.so'
+ 'gperftools')
+conflicts=('gperftools')
+optdepends=('graphviz: pprof graph generation'
+ 'gv: pprof postscript generation')
+source=("git+https://github.com/gperftools/gperftools.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/gperftools.//'
+}
+
+build() {
+ cd "$_pkgname"
+
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-frame-pointers
+ make
+}
+
+package() {
+ cd "$_pkgname"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: