summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicoHood2017-01-07 15:37:24 +0100
committerNicoHood2017-01-07 15:37:24 +0100
commitf9dbf21824b18f073a9dd6a6cd872c21ec57535e (patch)
tree9b984db8c348e2722e0e7f0390cd2234ee76b8b4
downloadaur-f9dbf21824b18f073a9dd6a6cd872c21ec57535e.tar.gz
Initital Release of gpgit 1.0.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5ab47d2b2ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gpgit
+ pkgdesc = A shell script that automates the process of signing git sources via gpg
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/NicoHood/gpgit
+ arch = any
+ license = MIT
+ depends = gnupg
+ depends = git
+ depends = bash
+ source = gpgit-1.0.0.tar.xz::https://github.com/NicoHood/gpgit/releases/download/1.0.0/gpgit-1.0.0.tar.xz
+ source = gpgit-1.0.0.tar.xz.sig::https://github.com/NicoHood/gpgit/releases/download/1.0.0/gpgit-1.0.0.tar.xz.sig
+ validpgpkeys = 97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161
+ sha512sums = 9b695e61e007a52e889e21f3145ab4aaca324615fe6eb2448d8bffbf09fa0b71ea2e3dbb8c0ff64f8f0a6531294d0ed65393412622b6330214636bacdb884fd6
+ sha512sums = SKIP
+
+pkgname = gpgit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87166e4b36a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: NicoHood <archlinux {cat} nicohood {dog} de>
+# PGP ID: 97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161
+
+pkgname=gpgit
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A shell script that automates the process of signing git sources via gpg "
+arch=('any')
+url="https://github.com/NicoHood/gpgit"
+license=('MIT')
+depends=('gnupg' 'git' 'bash')
+source=("${pkgname}-${pkgver}.tar.xz::https://github.com/NicoHood/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz"
+ "${pkgname}-${pkgver}.tar.xz.sig::https://github.com/NicoHood/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz.sig")
+sha512sums=('9b695e61e007a52e889e21f3145ab4aaca324615fe6eb2448d8bffbf09fa0b71ea2e3dbb8c0ff64f8f0a6531294d0ed65393412622b6330214636bacdb884fd6'
+ 'SKIP')
+validpgpkeys=('97312D5EB9D7AE7D0BD4307351DAE9B7C1AE9161') # NicoHood <archlinux {cat} nicohood {dog} de>
+
+package() {
+ make -C "${pkgname}-${pkgver}" DESTDIR="${pkgdir}" install
+ install -Dm 644 "${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}