summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfordprefect2021-03-26 12:44:03 +0100
committerfordprefect2021-03-26 12:44:03 +0100
commit5380baabf9d4a03154b3e043a1d95f997058f94f (patch)
treee4c3897bada064255876c4827de25eec60dc134f
parent14326f1904c16b271d5c691b8caf9a739307f9a4 (diff)
downloadaur-5380baabf9d4a03154b3e043a1d95f997058f94f.tar.gz
fixes: post_install message, dependencies, description
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
-rw-r--r--gplaycli.install2
3 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ed1c31409d4..5ae34c8797fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gplaycli
pkgdesc = command line tool to search/install/update Android applications Google PlayStore able to run with cronjob, in order to automatically update an F-Droid server instance
pkgver = 3.29
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/matlink/gplaycli
install = gplaycli.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 8d7cea4c0076..f9e94859b9e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=gplaycli
pkgver=3.29
_gpapi_ver=0.4.4.4
-pkgrel=1
-pkgdesc="command line tool to search/install/update Android applications Google PlayStore able to run with cronjob, in order to automatically update an F-Droid server instance"
+pkgrel=2
+pkgdesc="command line tool to search, install, update Android applications from the Google Play Store"
arch=('any')
url="https://github.com/matlink/gplaycli"
license=('AGPL')
-depends=('python' 'python-pyaxmlparser' 'python-setuptools' 'python-protobuf') # 'python-gpapi' temporarily replaced by adapted version
+depends=('python' 'python-pyaxmlparser' 'python-setuptools' 'python-protobuf' 'python-cryptography') # 'python-gpapi' temporarily replaced by adapted version
conflicts=('python-gpapi')
optdepends=('java-runtime: needed for autogeneration of a new AndroiID')
install=$pkgname.install
@@ -27,6 +27,12 @@ package() {
# install gplaycli
cd "$srcdir/$pkgname-$pkgver"
+
+ # fix for bug #272 (PR 273)
+ sed -i "s/splits = data_iter['splits']/splits = data_iter.get('splits')/g" gplaycli/gplaycli.py
+ # fix uploadDate (PR 266)
+ sed -i "s#details['uploadDate'],#details['uploadDate'] if ('uploadDate' in details) else 'N/A',#g" gplaycli/gplaycli.py
+
python setup.py install --root="$pkgdir/" --optimize=1
# installs config to build user home - moving to /usr/share
diff --git a/gplaycli.install b/gplaycli.install
index b1e8184a26ef..afbfbf2b3318 100644
--- a/gplaycli.install
+++ b/gplaycli.install
@@ -1,6 +1,6 @@
post_install() {
- echo "Standard config is found in /usr/share/gplaycli/config"
echo 'copy it to $HOME/.config/gplaycli to use standard credentials'
+ echo 'copy it to "$HOME/.local/etc/gplaycli/gplaycli.conf" or "/etc/gplaycli/gplaycli.conf"'
}
post_upgrade() {
post_install