summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2022-10-24 15:55:25 -0400
committerSolomon Choina2022-10-24 15:55:25 -0400
commit5ca2ce7e612179601e4c1849b7d53d6c3f567608 (patch)
treea797c492a38c5165d2ab5f06c59c5885c843efa5
parent098dc07a3de2aba6249a984c31c5bacf5997ec39 (diff)
downloadaur-5ca2ce7e612179601e4c1849b7d53d6c3f567608.tar.gz
updating pkgver and other stuff
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD48
2 files changed, 59 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e19b92396d9d..8b6e6d06d922 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = gplugin
pkgdesc = A GObject based library that implements a reusable plugin system
- pkgver = 0.29.0
- pkgrel = 1
- url = https://bitbucket.org/gplugin/gplugin
+ pkgver = 0.38.1
+ pkgrel = 2
+ url = https://keep.imfreedom.org/gplugin/gplugin
arch = i868
arch = x86_64
license = LGPL2
@@ -13,12 +13,29 @@ pkgbase = gplugin
makedepends = pkg-config
makedepends = help2man
makedepends = gettext
+ makedepends = gi-docgen
+ makedepends = lua-lgi
+ makedepends = perl-glib-object-introspection
+ makedepends = python-gobject
+ makedepends = vala
depends = gtk3
+ depends = gtk4
+ depends = glib-perl
+ depends = lua
+ depends = python
options = strip
options = !debug
options = staticlibs
- source = gplugin::hg+https://bitbucket.org/gplugin/gplugin#tag=v0.28.1
+ source = gplugin::hg+https://keep.imfreedom.org/gplugin/gplugin/#tag=v0.38.1
sha256sums = SKIP
pkgname = gplugin
+ depends = gtk3
+ depends = gtk4
+ depends = glib-perl
+ depends = lua
+ depends = python
+pkgname = gplugin-docs
+ pkgdesc = A GObject based library that implements a reusable plugin system (documentation)
+ depends =
diff --git a/PKGBUILD b/PKGBUILD
index 45a23cb0d1e7..ed32f8df3a54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,57 @@
# Maintainer: Darryl Pogue <darryl@dpogue.ca>
-pkgname="gplugin"
-pkgver=0.29.0
-pkgrel=1
+pkgbase=gplugin
+_pkgname=gplugin
+pkgname=(gplugin gplugin-docs)
+pkgver=0.38.1
+pkgrel=2
arch=('i868' 'x86_64')
-pkgdesc="A GObject based library that implements a reusable plugin system"
license=("LGPL2")
-url="https://bitbucket.org/gplugin/gplugin"
-depends=("gtk3")
+url="https://keep.imfreedom.org/gplugin/gplugin"
+pkgdesc="A GObject based library that implements a reusable plugin system"
+depends=("gtk3" "gtk4" "glib-perl" "lua" "python")
makedepends=("meson"
"mercurial"
"gcc"
"gobject-introspection"
"pkg-config"
"help2man"
- "gettext")
+ "gettext"
+ "gi-docgen"
+ "lua-lgi"
+ "perl-glib-object-introspection"
+ "python-gobject"
+ "vala")
options=('strip' '!debug' 'staticlibs')
-source=("$pkgname::hg+https://bitbucket.org/$pkgname/$pkgname#tag=v$pkgver")
+source=("$pkgname::hg+https://keep.imfreedom.org/$_pkgname/$_pkgname/#tag=v$pkgver")
sha256sums=('SKIP')
+_pick() {
+ local p="$1" f d; shift
+ for f; do
+ d="$srcdir/$p/${f#$pkgdir/}"
+ mkdir -p "$(dirname "$d")"
+ mv "$f" "$d"
+ rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
+ done
+}
+
build() {
- meson --prefix /usr --buildtype=plain -D doc=false -D perl=false -D python=false -D lua=false -D tcl=false "$srcdir/$pkgname" build
+ arch-meson gplugin build
ninja -C build
}
-package() {
+package_gplugin() {
+ depends=("gtk3" "gtk4" "glib-perl" "lua" "python")
DESTDIR="$pkgdir" ninja -C build install
+
+ cd "$pkgdir"
+ _pick docs usr/share/doc/gplugin*
+}
+
+
+package_gplugin-docs() {
+ pkgdesc+=" (documentation)"
+ depends=()
+ mv docs/* "$pkgdir"
}