summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-09-17 13:27:09 +0800
committerChocobo12020-09-17 13:37:38 +0800
commit6f72b57c2ff50c81f090cfe4c3162fcfc5f00238 (patch)
tree0172d8a4fe0fafb009cd34a252199e259815fe68
downloadaur-6f72b57c2ff50c81f090cfe4c3162fcfc5f00238.tar.gz
newpkg: gpm-git 1.20.7.r38.ge82d1a6-1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD53
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d136783a3f77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gpm-git
+ pkgdesc = General purpose mouse daemon
+ pkgver = 1.20.7.r38.ge82d1a6
+ pkgrel = 1
+ url = https://www.nico.schottelius.org/software/gpm/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = glibc
+ provides = gpm
+ provides = libgpm.so
+ conflicts = gpm
+ options = staticlibs
+ source = git+https://github.com/telmich/gpm.git
+ source = https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/gpm/trunk/gpm.service
+ source = https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/gpm/trunk/gpm.sh
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = gpm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4341510bce51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=gpm-git
+pkgver=1.20.7.r38.ge82d1a6
+pkgrel=1
+pkgdesc="General purpose mouse daemon"
+arch=('i686' 'x86_64')
+url="https://www.nico.schottelius.org/software/gpm/"
+license=('GPL')
+depends=('glibc')
+makedepends=('git')
+provides=('gpm' 'libgpm.so')
+conflicts=('gpm')
+options=('staticlibs')
+source=("git+https://github.com/telmich/gpm.git"
+ "https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/gpm/trunk/gpm.service"
+ "https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/gpm/trunk/gpm.sh")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+
+pkgver() {
+ cd "gpm"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "gpm"
+
+ ./autogen.sh
+ ./configure \
+ --prefix="/usr" \
+ --sbindir="/usr/bin" \
+ --sysconfdir="/etc"
+ make
+}
+
+check() {
+ cd "gpm"
+
+ make check
+}
+
+package() {
+ cd "gpm"
+
+ make DESTDIR="$pkgdir" install
+
+ install -Dm755 "$srcdir/gpm.sh" -t "$pkgdir/etc/profile.d"
+ install -Dm644 "$srcdir/gpm.service" -t "$pkgdir/usr/lib/systemd/system"
+}