summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames P. Harvey2019-08-18 23:07:26 -0400
committerJames P. Harvey2019-08-18 23:10:00 -0400
commit61d4e34d9704d143b0da836b66dc8abfa63dd5bb (patch)
tree4b7e5500094c8249ddd1226e96cfca4c8be1a9ab
parenta3760dda277e84a8fc0016619a3ac5f7830283d5 (diff)
downloadaur-61d4e34d9704d143b0da836b66dc8abfa63dd5bb.tar.gz
Allow setting additional arguments for gpm in '/etc/gpm-vm.conf'.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xgpm-vm6
-rw-r--r--gpm-vm.conf1
4 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c42ec93702aa..fceb2fe9aa48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,8 +23,8 @@ pkgbase = gpm-vm
sha256sums = f41e90dcf6c0c6c4b8eff1c69039a20eb6b38ea851ffd1fa47ba311bf83d6ed8
sha256sums = 4d1e92a82006a7d361deeb8760514bbf1b33b40264bb57a4f4087239009d0485
sha256sums = f9f228a17701afcf383396861cfe798067505b4dbfddbb4fa91ee3e4c5088175
- sha256sums = 92c6040e43617fe1aaf3af45c63c211e9de6a2728fc005aef32a5aebe4bcfe19
- sha256sums = a0b57507017158316facb9e603b187dc443fbe934ed024ceea94715565843d4f
+ sha256sums = 4bad510d05315ed02defe3abd6f41660cb384290a8d93e9f5c6f23269c24c21d
+ sha256sums = 8992300b9636b26864a2930a70ef78e52300432c614865c36885c53f1f7e546f
pkgname = gpm-vm
diff --git a/PKGBUILD b/PKGBUILD
index 83646c45be7b..8331b39d55e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,8 +29,8 @@ sha256sums=('SKIP'
'f41e90dcf6c0c6c4b8eff1c69039a20eb6b38ea851ffd1fa47ba311bf83d6ed8'
'4d1e92a82006a7d361deeb8760514bbf1b33b40264bb57a4f4087239009d0485'
'f9f228a17701afcf383396861cfe798067505b4dbfddbb4fa91ee3e4c5088175'
- '92c6040e43617fe1aaf3af45c63c211e9de6a2728fc005aef32a5aebe4bcfe19'
- 'a0b57507017158316facb9e603b187dc443fbe934ed024ceea94715565843d4f')
+ '4bad510d05315ed02defe3abd6f41660cb384290a8d93e9f5c6f23269c24c21d'
+ '8992300b9636b26864a2930a70ef78e52300432c614865c36885c53f1f7e546f')
provides=('gpm')
conflicts=('gpm')
diff --git a/gpm-vm b/gpm-vm
index f2e1cf780301..c8de00420523 100755
--- a/gpm-vm
+++ b/gpm-vm
@@ -19,4 +19,8 @@ if [[ ! -c "${event}" ]]; then
exit 1
fi
-/usr/bin/gpm -m "${event}" -t vbox
+if [[ ! -v additional_args ]]; then
+ additional_args=""
+fi
+
+/usr/bin/gpm -m "${event}" -t vbox "${additional_args}"
diff --git a/gpm-vm.conf b/gpm-vm.conf
index c4e15f7af636..dabcaf2a2537 100644
--- a/gpm-vm.conf
+++ b/gpm-vm.conf
@@ -1 +1,2 @@
event="/dev/input/event2"
+#additional_args=""