summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Allred2016-05-30 20:02:44 -0500
committerBrian Allred2016-05-30 20:02:44 -0500
commitb30c776f960c889584f65d901e0b3524d094b13d (patch)
treed5f0708dda84f524f31c987dd801024c63a1efc2
parent4d560ac63973548c34498341bd650eef67361f30 (diff)
downloadaur-b30c776f960c889584f65d901e0b3524d094b13d.tar.gz
Fix desktop file by providing custom one. Also abbreviate long name to gpmdp.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD27
-rw-r--r--gpmdp.desktop10
3 files changed, 32 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f42a30a932a..4d49a3694009 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Apr 30 20:51:12 UTC 2016
+# Tue May 31 00:42:06 UTC 2016
pkgbase = gpmdp
pkgdesc = A beautiful cross platform Desktop Player for Google Play Music. Stable release.
pkgver = 3.2.4
- pkgrel = 1
+ pkgrel = 2
url = http://www.googleplaymusicdesktopplayer.com
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9a4f3c019ecd..384c5ffbdb92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,10 @@
pkgname=gpmdp
pkgver=3.2.4
-pkgrel=1
+pkgrel=2
pkgdesc="A beautiful cross platform Desktop Player for Google Play Music. Stable release."
arch=('i686' 'x86_64')
url="http://www.googleplaymusicdesktopplayer.com"
-source=("https://github.com/MarshallOfSound/Google-Play-Music-Desktop-Player-UNOFFICIAL-")
depends=('libnotify' 'alsa-lib' 'gconf' 'gtk2' 'nss')
optdepends=('gnome-keyring' 'lsb-release' 'libxtst')
license=('MIT')
@@ -15,18 +14,32 @@ license=('MIT')
case $CARCH in
'x86_64')
_arch='amd64'
- md5sums=('b38ee2ce8bd4a213c3d9de38860ef672')
+ md5sums=('b38ee2ce8bd4a213c3d9de38860ef672'
+ '1b9aa95549ba9b1d360cda0152b0a168')
;;
'i686')
_arch='i386'
- md5sums=('6faf476948590f840b28a5201dc59d9a')
+ md5sums=('6faf476948590f840b28a5201dc59d9a'
+ '1b9aa95549ba9b1d360cda0152b0a168')
;;
esac
-source=("https://github.com/MarshallOfSound/Google-Play-Music-Desktop-Player-UNOFFICIAL-/releases/download/v${pkgver}/google-play-music-desktop-player_${pkgver}_${_arch}.deb")
+source=("https://github.com/MarshallOfSound/Google-Play-Music-Desktop-Player-UNOFFICIAL-/releases/download/v${pkgver}/google-play-music-desktop-player_${pkgver}_${_arch}.deb"
+ "gpmdp.desktop")
package() {
+ # Extract
tar -xf data.tar.xz -C "${pkgdir}"
- rm -rf "${pkgdir}"/usr/share/lintian
- chmod -R 755 "${pkgdir}"/usr
+ cd "${pkgdir}"
+ rm -rf usr/share/lintian
+ rm -f usr/share/applications/google-play-music-desktop-player.desktop
+ rm -f usr/bin/google-play-music-desktop-player
+ chmod -R 755 usr
+
+ # Rename
+ mv usr/share/doc/google-play-music-desktop-player usr/share/doc/gpmdp
+ mv usr/share/google-play-music-desktop-player usr/share/gpmdp
+ mv usr/share/pixmaps/google-play-music-desktop-player.png usr/share/pixmaps/gpmdp.png
+ ln -s "/usr/share/gpmdp/Google Play Music Desktop Player" "usr/bin/gpmdp"
+ cp $srcdir/gpmdp.desktop usr/share/applications/
}
diff --git a/gpmdp.desktop b/gpmdp.desktop
new file mode 100644
index 000000000000..808aab5d1b03
--- /dev/null
+++ b/gpmdp.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Google Play Music Desktop Player
+Comment=An electron wrapper for Google Play Music
+GenericName=Google Play Music Desktop Player
+Exec=gpmdp %U
+Icon=gpmdp
+Type=Application
+StartupNotify=true
+Categories=GNOME;GTK;Multimedia;
+StartupWMClass=Google Play Music Desktop Player