summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Minehart2016-03-06 21:30:05 -0600
committerKevin Minehart2016-03-06 21:30:05 -0600
commitf5cc8aa284ae62254e9d95c0f0dfe8192397f6d4 (patch)
treea9e0508ed89b6342d1d1a57e7602ba5e3b783bb0
downloadaur-f5cc8aa284ae62254e9d95c0f0dfe8192397f6d4.tar.gz
Initialized repository.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b37f33fb591
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by makepkg 5.0.0
+# Mon Mar 7 03:29:41 UTC 2016
+pkgbase = gpmdp-git
+ pkgdesc = An electron wrapper for Google Play Music
+ pkgver = r362.ba5539f
+ pkgrel = 1
+ url = https://github.com/MarshallOfSound/Google-Play-Music-Desktop-Player-UNOFFICIAL-
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = npm
+ depends = nodejs
+ provides = gpmdp-git
+ conflicts = gpmdp-git
+ conflicts = gpmdp
+ source = ::git+https://github.com/MarshallOfSound/Google-Play-Music-Desktop-Player-UNOFFICIAL-.git#branch=master
+ md5sums = SKIP
+
+pkgname = gpmdp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4feefcbb22df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Kevin Minehart <kmineh0151@gmail.com>
+pkgname=gpmdp-git
+_gitname=Google-Play-Music-Desktop-Player-UNOFFICIAL-
+pkgver=r362.ba5539f
+pkgrel=1
+pkgdesc="An electron wrapper for Google Play Music"
+arch=('x86_64')
+url="https://github.com/MarshallOfSound/Google-Play-Music-Desktop-Player-UNOFFICIAL-"
+license=('MIT')
+depends=('nodejs')
+makedepends=('git' 'npm') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("$pkgname")
+conflicts=("$pkgname" 'gpmdp')
+source=($gitname::'git+https://github.com/MarshallOfSound/Google-Play-Music-Desktop-Player-UNOFFICIAL-.git#branch=master')
+md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$_gitname"
+ npm install
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ npm run package:linux
+}
+
+package() {
+ cd "$srcdir/$_gitname/dist/"
+ mkdir -p $pkgdir/usr/share/ $pkgdir/usr/bin
+ mv 'Google Play Music Desktop Player-linux-x64' $pkgdir/usr/share/google-play-music-desktop-player
+ ln -sf '/usr/share/google-play-music-desktop-player/Google Play Music Desktop Player' $pkgdir/usr/bin/google-play-music-desktop-player
+}
+