summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Allred2020-01-07 21:09:24 -0600
committerBrian Allred2020-01-07 21:09:24 -0600
commitd73eeadae6e836fdf93530586fb02d37861abd84 (patch)
treeb3112d7355d4b2229d075b34cfbf589dc754f8f9
downloadaur-d73eeadae6e836fdf93530586fb02d37861abd84.tar.gz
0.1.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
-rw-r--r--gpmdp2text.install7
-rw-r--r--gpmdp2text.service9
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a33664dda15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gpmdp2text-bin
+ pkgdesc = Utility that reads from GPMDP's JSON API and outputs the information in plain text.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/BrianAllred/gpmdp2text
+ install = gpmdp2text.install
+ arch = x86_64
+ license = MIT
+ depends = gpmdp
+ provides = gpmdp2text
+ options = staticlibs
+ source = https://github.com/BrianAllred/gpmdp2text/releases/download/v0.1.0/gpmdp2text-linux-x64-v0.1.0.tar.gz
+ source = gpmdp2text.service
+ md5sums = 7b8eb68dc094793581e1ce095d43481f
+ md5sums = 413b33ec845277d9dc882dca187f7fe6
+
+pkgname = gpmdp2text-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d309d48b6d0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Brian Allred <brian.d.allred@gmail.com>
+# This script is licensed under the MIT license.
+
+pkgname=gpmdp2text-bin
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Utility that reads from GPMDP's JSON API and outputs the information in plain text."
+arch=('x86_64')
+url="https://github.com/BrianAllred/gpmdp2text"
+depends=('gpmdp')
+provides=('gpmdp2text')
+license=('MIT')
+source=("https://github.com/BrianAllred/gpmdp2text/releases/download/v${pkgver}/gpmdp2text-linux-x64-v${pkgver}.tar.gz"
+ "gpmdp2text.service")
+md5sums=('7b8eb68dc094793581e1ce095d43481f'
+ '413b33ec845277d9dc882dca187f7fe6')
+options=(staticlibs)
+install=gpmdp2text.install
+
+package() {
+ mkdir -p "${pkgdir}"/opt/gpmdp2text
+ mkdir -p "${pkgdir}"/usr/bin
+ mkdir -p "${pkgdir}"/usr/lib/systemd/user
+ cp -r "${srcdir}"/* "${pkgdir}"/opt/gpmdp2text/
+ cp gpmdp2text.service "${pkgdir}"/usr/lib/systemd/user/
+ rm -rf "${pkgdir}"/opt/gpmdp2text/gpmdp2text-linux-x64*.tar.gz
+ chmod -R 755 "${pkgdir}"/opt
+ ln -s /opt/gpmdp2text/gpmdp2text "${pkgdir}"/usr/bin/gpmdp2text
+}
diff --git a/gpmdp2text.install b/gpmdp2text.install
new file mode 100644
index 000000000000..62293b42f0bb
--- /dev/null
+++ b/gpmdp2text.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo -e "Don't forget to enable gpmdp2text.service with the command \"systemctl --user enable --now gpmdp2text.service\""
+}
+
+post_upgrade() {
+ post_install
+} \ No newline at end of file
diff --git a/gpmdp2text.service b/gpmdp2text.service
new file mode 100644
index 000000000000..9215341f4fcf
--- /dev/null
+++ b/gpmdp2text.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Utility to read GPMDP's JSON API and output as plain text
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/gpmdp2text
+
+[Install]
+WantedBy=default.target \ No newline at end of file