summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Magnus Brevik2018-01-30 13:11:01 +0100
committerJan Magnus Brevik2018-01-30 13:11:01 +0100
commit7c96c2176945d9cff2c44976eb6166092b5b9ffe (patch)
tree88566bf98ef205080a57254a9e252466d059c66e
parentf50b3c55b3f8ccea953a9f519ab87ad0c415679a (diff)
downloadaur-7c96c2176945d9cff2c44976eb6166092b5b9ffe.tar.gz
bump v3.10.0
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD26
2 files changed, 25 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f91ec8fad8f..ea52921be85b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gpodder3
pkgdesc = A podcast receiver/catcher
- pkgver = 3.9.3
+ pkgver = 3.10.0
pkgrel = 1
url = http://gpodder.org/
install = gpodder.install
@@ -9,25 +9,24 @@ pkgbase = gpodder3
makedepends = intltool
makedepends = imagemagick
makedepends = help2man
- depends = iproute2
- depends = pygtk
- depends = python2-dbus
- depends = python2-podcastparser
- depends = python2-mygpoclient
+ depends = python-dbus
+ depends = python-podcastparser
+ depends = python-mygpoclient
+ depends = python-gobject
optdepends = libgpod: for ipod support
- optdepends = lame: for converting ogg to mp3
optdepends = gnome-bluetooth: transfer podcast via bluethooth
- optdepends = pywebkitgtk: html shownotes/flattr integration
- optdepends = python2-eyed3: for ipod support
+ optdepends = lame: for converting ogg to mp3
+ optdepends = python-eyed3: for ipod support
optdepends = ffmpeg: transcode audio files to mp3/ogg
optdepends = mutagen: audio tagging
- optdepends = python2-html5lib: clickable links
+ optdepends = webkit2gtk: HTML show notes
+ optdepends = python-html5lib: clickable links
conflicts = gpodder
conflicts = gpodder2
conflicts = gpodder-git
- source = gpodder-3.9.3.tar.gz::http://gpodder.org/source/3.9.3
- md5sums = 56d891649d9ac8a0b9c5e47471a8119f
- sha1sums = 77aa49442fe3abe9aa84f69f5be5319cf5f6cb0b
+ source = gpodder-3.10.0.tar.gz::http://github.com/gpodder/gpodder/archive/gpodder-3.10.0
+ md5sums = 2303a104690a614935f06f5c6d2ab3ef
+ sha1sums = bae623e6465f28d75c75170279ffd4e51d3769c7
pkgname = gpodder3
diff --git a/PKGBUILD b/PKGBUILD
index 87b755718da4..3773d5f4a85c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,34 @@
pkgname=gpodder3
_pkgname=gpodder
-pkgver=3.9.3
+pkgver=3.10.0
pkgrel=1
pkgdesc='A podcast receiver/catcher'
license=('GPL3')
arch=('any')
url='http://gpodder.org/'
conflicts=('gpodder' 'gpodder2' 'gpodder-git')
-depends=('iproute2' 'pygtk' 'python2-dbus' 'python2-podcastparser' 'python2-mygpoclient')
+depends=('python-dbus' 'python-podcastparser' 'python-mygpoclient' 'python-gobject')
makedepends=('intltool' 'imagemagick' 'help2man')
optdepends=('libgpod: for ipod support'
- 'lame: for converting ogg to mp3'
'gnome-bluetooth: transfer podcast via bluethooth'
- 'pywebkitgtk: html shownotes/flattr integration'
- 'python2-eyed3: for ipod support'
+ 'lame: for converting ogg to mp3'
+ 'python-eyed3: for ipod support'
'ffmpeg: transcode audio files to mp3/ogg'
'mutagen: audio tagging'
- 'python2-html5lib: clickable links')
-source=("${_pkgname}-${pkgver}.tar.gz::http://${_pkgname}.org/source/${pkgver}")
+ 'webkit2gtk: HTML show notes'
+ 'python-html5lib: clickable links')
+source=("${_pkgname}-${pkgver}.tar.gz::http://github.com/${_pkgname}/${_pkgname}/archive/${_pkgname}-${pkgver}")
install=gpodder.install
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- PYTHON=python2 DESTDIR=${pkgdir} make install || return 1
+ PYTHON=python DESTDIR=${pkgdir} make install || return 1
- sed -i -e 's|#!/usr/bin/python$|#!/usr/bin/python2|' \
- -e 's|#!/usr/bin/env python$|#!/usr/bin/env python2|' \
- $(find $pkgdir/usr/lib/python2.7/site-packages/gpodder/ -name '*.py')
+ sed -i -e 's|#!/usr/bin/python$|#!/usr/bin/python|' \
+ -e 's|#!/usr/bin/env python$|#!/usr/bin/env python|' \
+ $(find $pkgdir/usr/lib/python3.6/site-packages/gpodder/ -name '*.py')
}
-md5sums=('56d891649d9ac8a0b9c5e47471a8119f')
-sha1sums=('77aa49442fe3abe9aa84f69f5be5319cf5f6cb0b')
+md5sums=('2303a104690a614935f06f5c6d2ab3ef')
+sha1sums=('bae623e6465f28d75c75170279ffd4e51d3769c7')