summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2018-09-12 03:05:07 +1000
committerRod Kay2018-09-12 03:05:07 +1000
commit0f5be2366ed9b77cc4f113f1cf987d9de1a69cd3 (patch)
treed183a6bdb3dfc403e4f68033992e33901db010de
parentfeeea0358d92a16ce3abc58483fe27e6100d02e2 (diff)
downloadaur-0f5be2366ed9b77cc4f113f1cf987d9de1a69cd3.tar.gz
Improve PKGBUILD
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34abececa6e7..54a682ce5983 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = gprbuild
pkgdesc = Builder for multi-language systems
pkgver = 2018
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/AdaCore/gprbuild/
arch = i686
arch = x86_64
license = GPL3
- makedepends = gprbuild-bootstrap
- makedepends = libgpr
- depends = libgpr
- provides = gprbuild
- provides = gprbuild-bootstrap
- conflicts = gprbuild
- conflicts = gprbuild-bootstrap
+ makedepends = gprbuild-bootstrap>=2018
+ depends = libgpr>=2018
+ provides = gprbuild-bootstrap=2018
+ conflicts = gprbuild-bootstrap-git
+ conflicts = gprbuild-git
source = http://mirrors.cdn.adacore.com/art/5b0819dfc7a447df26c27a68
source = relocatable-build.patch
source = expose-cargs-and-largs-makefile.patch
diff --git a/PKGBUILD b/PKGBUILD
index 2cd9e78ac43a..b30b8508b79f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
-# Maintainer: Pierre-Marie de Rodat <pmderodat on #ada at freenode.net>
-# Contributor: Rod Kay <charlie5 on #ada at freenode.net>
+# Maintainer: Rod Kay <charlie5 on #ada at freenode.net>
+# Contributor: Pierre-Marie de Rodat <pmderodat on #ada at freenode.net>
# Contributor: Earnestly <zibeon AT googlemail.com>
pkgname=gprbuild
pkgver=2018
-pkgrel=1
+pkgrel=2
pkgdesc="Builder for multi-language systems"
arch=('i686' 'x86_64')
url="https://github.com/AdaCore/gprbuild/"
license=('GPL3')
-depends=('libgpr')
-makedepends=('gprbuild-bootstrap' 'libgpr')
+depends=('libgpr>=2018')
+makedepends=('gprbuild-bootstrap>=2018')
+
+# Provides gprbuild-bootstrap to satisfy xmlada & libgpr needs, if they are rebuilt.
+provides=("gprbuild-bootstrap=2018")
+conflicts=("gprbuild-bootstrap-git" "gprbuild-git")
-# gprbuild-bootstrap is here only to bootstrap gprbuild and xmlada
-provides=("${pkgname%}" "gprbuild-bootstrap")
-conflicts=("${pkgname%}" "gprbuild-bootstrap")
source=('http://mirrors.cdn.adacore.com/art/5b0819dfc7a447df26c27a68'
'relocatable-build.patch'
'expose-cargs-and-largs-makefile.patch')
@@ -27,6 +28,7 @@ DEBUG_CFLAGS="-g"
prepare() {
cd "$srcdir/gprbuild-gpl-2018-src"
+
patch -Np1 -i "$srcdir/relocatable-build.patch"
patch -Np1 -i "$srcdir/expose-cargs-and-largs-makefile.patch"
@@ -40,8 +42,10 @@ prepare() {
build() {
cd "$srcdir/gprbuild-gpl-2018-src"
- make prefix=/usr BUILD=production PROCESSORS="$(nproc)" setup
- make GPRBUILD_OPTIONS=-R BUILD=production
+
+ # Make using a single job (-j1) to avoid the same file being compiled at the same time.
+ make -j1 prefix=/usr BUILD=production setup
+ make -j1 GPRBUILD_OPTIONS=-R BUILD=production
}
package() {