summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2016-06-06 07:24:37 +1000
committerRod Kay2016-06-06 07:24:37 +1000
commit5f9866cd580c2a222e4a1e9adbfd8cfb0439aac6 (patch)
treef851533893a109546654ca14a1db0f80e1b17e10
parentbc0e6014f63ec452e0e37b5f4474d557d434c332 (diff)
downloadaur-5f9866cd580c2a222e4a1e9adbfd8cfb0439aac6.tar.gz
Rid obsolete 'Makefile.archy'.
-rw-r--r--.SRCINFO2
-rw-r--r--Makefile.archy111
-rw-r--r--PKGBUILD9
-rw-r--r--patch-gnat_targparm302
4 files changed, 1 insertions, 423 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0603ecf1fc78..b97d836d02a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jun 5 02:51:17 UTC 2016
+# Sun Jun 5 21:24:13 UTC 2016
pkgbase = gprbuild
pkgdesc = Software tool designed to help automate the construction of multi-language systems
pkgver = 2016
diff --git a/Makefile.archy b/Makefile.archy
deleted file mode 100644
index 0e9a29f44042..000000000000
--- a/Makefile.archy
+++ /dev/null
@@ -1,111 +0,0 @@
-.PHONY: all
-.PHONY: generate_sources
-
-AFLAGS= -gnat12 -gnaty -gnatQ -O2 -gnatpn -gnatws -g1 -j7
-
-COBJS= obj/link.o obj/gprbuild_dummies.o
-
-CURRENT_FOLDER=$(shell pwd)
-
-
-LOOK= -aI${CURRENT_FOLDER}/gnat -aI${CURRENT_FOLDER}/gen_src \
- -aL${PREFIX}/lib/xmlada/static -aI${PREFIX}/include/xmlada
-
-LARGS= -largs ${CURRENT_FOLDER}/obj/link.o \
- -largs ${CURRENT_FOLDER}/obj/gprbuild_dummies.o \
- -largs ${PREFIX}/lib/xmlada/static/libxmlada_dom.a \
- -largs ${PREFIX}/lib/xmlada/static/libxmlada_input_sources.a \
- -largs ${PREFIX}/lib/xmlada/static/libxmlada_sax.a \
- -largs ${PREFIX}/lib/xmlada/static/libxmlada_schema.a \
- -largs ${PREFIX}/lib/xmlada/static/libxmlada_unicode.a
-
-GENDIR= gen_src
-GEN_SRCS= ${GENDIR}/snames.adb ${GENDIR}/snames.ads
-DOCSDIR= ${PREFIX}/share/doc/gprbuild
-
-
-BSD_INSTALL_PROGRAM=install
-BSD_INSTALL_DATA=install
-
-
-all: gprbuild
-
-install:
- mkdir -p ${DESTDIR}${PREFIX}/bin \
- ${DESTDIR}${PREFIX}/libexec/gprbuild \
- ${DESTDIR}${PREFIX}/share/gpr \
- ${DESTDIR}${PREFIX}/share/gprconfig
-
- ${BSD_INSTALL_PROGRAM} \
- ${CURRENT_FOLDER}/gprclean \
- ${CURRENT_FOLDER}/gprinstall \
- ${CURRENT_FOLDER}/gprconfig \
- ${CURRENT_FOLDER}/gprslave \
- ${CURRENT_FOLDER}/gprbuild ${DESTDIR}${PREFIX}/bin
-
- ${BSD_INSTALL_PROGRAM} ${CURRENT_FOLDER}/gprbind \
- ${CURRENT_FOLDER}/gprlib ${DESTDIR}${PREFIX}/libexec/gprbuild
-
- ${BSD_INSTALL_DATA} ${CURRENT_FOLDER}/share/_default.gpr \
- ${DESTDIR}${PREFIX}/share/gpr
-
- ${BSD_INSTALL_DATA} ${CURRENT_FOLDER}/share/gprconfig/* \
- ${DESTDIR}${PREFIX}/share/gprconfig
-
-install-docs:
- mkdir -p ${DESTDIR}${DOCSDIR}/html ${DESTDIR}${DOCSDIR}/txt \
- ${DESTDIR}${DOCSDIR}/pdf
- ${BSD_INSTALL_DATA} ${CURRENT_FOLDER}/doc/txt/gprbuild_ug.txt \
- ${DESTDIR}${DOCSDIR}/txt
- ${BSD_INSTALL_DATA} ${CURRENT_FOLDER}/doc/pdf/gprbuild_ug.pdf \
- ${DESTDIR}${DOCSDIR}/pdf
- cp -r ${CURRENT_FOLDER}/doc/html/* ${DESTDIR}${DOCSDIR}/html
- rm -rf ${DESTDIR}${DOCSDIR}/html/_sources
- ${BSD_INSTALL_DATA} ${CURRENT_FOLDER}/doc/*.png \
- ${DESTDIR}${DOCSDIR}/html
-
-gprclean: src/gprclean-main.adb ${GEN_SRCS} ${COBJS}
- gnatmake -o gprclean ${AFLAGS} ${LOOK} \
- ${CURRENT_FOLDER}/src/gprclean-main.adb ${LARGS}
-
-gprbind: gprclean src/gprslave.adb ${GEN_SRCS} ${COBJS}
- gnatmake -o gprbind ${AFLAGS} ${LOOK} \
- ${CURRENT_FOLDER}/src/gprbind.adb ${LARGS}
-
-gprlib: gprbind src/gprslave.adb ${GEN_SRCS} ${COBJS}
- gnatmake -o gprlib ${AFLAGS} ${LOOK} \
- ${CURRENT_FOLDER}/src/gprlib.adb ${LARGS}
-
-gprslave: gprlib src/gprslave.adb ${GEN_SRCS} ${COBJS}
- gnatmake -o gprslave ${AFLAGS} ${LOOK} \
- ${CURRENT_FOLDER}/src/gprslave.adb ${LARGS}
-
-gprinstall: gprslave src/gprinstall-main.adb ${GEN_SRCS} ${COBJS}
- gnatmake -o gprinstall ${AFLAGS} ${LOOK} \
- ${CURRENT_FOLDER}/src/gprinstall-main.adb ${LARGS}
-
-gprconfig: gprinstall src/gprconfig-main.adb ${GEN_SRCS} ${COBJS}
- gnatmake -o gprconfig ${AFLAGS} ${LOOK} \
- ${CURRENT_FOLDER}/src/gprconfig-main.adb ${LARGS}
-
-gprbuild: gprconfig src/gprbuild-main.adb ${GEN_SRCS} ${COBJS}
- gnatmake -o gprbuild ${AFLAGS} ${LOOK} \
- ${CURRENT_FOLDER}/src/gprbuild-main.adb ${LARGS}
-
-obj/link.o: gnat/link.c
- gcc -c -o ${CURRENT_FOLDER}/obj/link.o gnat/link.c
-
-obj/gprbuild_dummies.o: src/gprbuild_dummies.c
- gcc -c -o ${CURRENT_FOLDER}/obj/gprbuild_dummies.o src/gprbuild_dummies.c
-
-generate_sources:
- mkdir -p ${CURRENT_FOLDER}/${GENDIR}
- (cd ${CURRENT_FOLDER}/gnat && cp xsnamest.adb xutil.* snames.adb-tmpl \
- snames.ads-tmpl snames.h-tmpl ../${GENDIR})
- (cd ${CURRENT_FOLDER}/${GENDIR} && \
- gnatmake -gnatf -gnatwae -gnatyg -gnatyS xsnamest && \
- ./xsnamest && \
- mv snames.ns snames.ads && \
- mv snames.nb snames.adb)
-
-${GEN_SRCS}: generate_sources
diff --git a/PKGBUILD b/PKGBUILD
index 55fb81ef978d..edff827ebb38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,15 +18,6 @@ sha256sums=('d51659454bc0aaf1a9a9f1d05aab469a1f3d900065a4542123d3a59ab067275d')
-prepare()
-{
- WRKSRC=$srcdir/$pkgname-gpl-$pkgver-src
-
- cp $srcdir/Makefile.archy ${WRKSRC}
-}
-
-
-
build()
{
cd $pkgname-gpl-$pkgver-src
diff --git a/patch-gnat_targparm b/patch-gnat_targparm
deleted file mode 100644
index b52527689a96..000000000000
--- a/patch-gnat_targparm
+++ /dev/null
@@ -1,302 +0,0 @@
-These restriction pragmas are not yet supported on FSF GNAT 5:
- No_Specification_Of_Aspect
- No_Use_Of_Attribute
- No_Use_Of_Pragma
-
---- gnat/targparm.ads.orig 2015-05-06 11:08:38 UTC
-+++ gnat/targparm.ads
-@@ -615,53 +615,28 @@ package Targparm is
- -- selected component with Sloc value System_Location and given Prefix
- -- (Pre) and Selector (Sel) values.
-
-- type Set_NOD_Type is access procedure (Unit : Node_Id);
-+ type Set_RND_Type is access procedure (Unit : Node_Id);
- -- Parameter type for Get_Target_Parameters that records a Restriction
- -- No_Dependence for the given unit (identifier or selected component).
-
-- type Set_NSA_Type is access procedure (Asp : Name_Id; OK : out Boolean);
-- -- Parameter type for Get_Target_Parameters that records a Restriction
-- -- No_Specification_Of_Aspect. Asp is the aspect name. OK is set True
-- -- if this is an OK aspect name, and False if it is not an aspect name.
--
-- type Set_NUA_Type is access procedure (Attr : Name_Id; OK : out Boolean);
-- -- Parameter type for Get_Target_Parameters that records a Restriction
-- -- No_Use_Of_Attribute. Attr is the attribute name. OK is set True if
-- -- this is an OK attribute name, and False if it is not an attribute name.
--
-- type Set_NUP_Type is access procedure (Prag : Name_Id; OK : out Boolean);
-- -- Parameter type for Get_Target_Parameters that records a Restriction
-- -- No_Use_Of_Pragma. Prag is the pragma name. OK is set True if this is
-- -- an OK pragma name, and False if it is not a recognized pragma name.
--
- procedure Get_Target_Parameters
- (System_Text : Source_Buffer_Ptr;
- Source_First : Source_Ptr;
- Source_Last : Source_Ptr;
- Make_Id : Make_Id_Type := null;
- Make_SC : Make_SC_Type := null;
-- Set_NOD : Set_NOD_Type := null;
-- Set_NSA : Set_NSA_Type := null;
-- Set_NUA : Set_NUA_Type := null;
-- Set_NUP : Set_NUP_Type := null);
-- -- Called at the start of execution to obtain target parameters from the
-- -- source of package System. The parameters provide the source text to be
-- -- scanned (in System_Text (Source_First .. Source_Last)). If the three
-- -- subprograms Make_Id, Make_SC, and Set_NOD are left at their default
-- -- value of null, Get_Target_Parameters will ignore pragma Restrictions
-- -- (No_Dependence) lines; otherwise it will use these three subprograms to
-- -- record them. Similarly, if Set_NUP is left at its default value of null,
-- -- then any occurrences of pragma Restrictions (No_Use_Of_Pragma => XXX)
-- -- will be ignored; otherwise it will use this procedure to record the
-- -- pragma. Similarly for the NSA and NUA cases.
-+ Set_RND : Set_RND_Type := null);
-+ -- Called at the start of execution to obtain target parameters from
-+ -- the source of package System. The parameters provide the source
-+ -- text to be scanned (in System_Text (Source_First .. Source_Last)).
-+ -- if the three subprograms are left at their default value of null,
-+ -- Get_Target_Parameters will ignore pragma Restrictions No_Dependence
-+ -- lines, otherwise it will use these three subprograms to record them.
-
- procedure Get_Target_Parameters
- (Make_Id : Make_Id_Type := null;
- Make_SC : Make_SC_Type := null;
-- Set_NOD : Set_NOD_Type := null;
-- Set_NSA : Set_NSA_Type := null;
-- Set_NUA : Set_NUA_Type := null;
-- Set_NUP : Set_NUP_Type := null);
-+ Set_RND : Set_RND_Type := null);
- -- This version reads in system.ads using Osint. The idea is that the
- -- caller uses the first version if they have to read system.ads anyway
- -- (e.g. the compiler) and uses this simpler interface if system.ads is
---- gnat/targparm.adb.orig 2015-05-06 11:08:38 UTC
-+++ gnat/targparm.adb
-@@ -154,10 +154,7 @@ package body Targparm is
- procedure Get_Target_Parameters
- (Make_Id : Make_Id_Type := null;
- Make_SC : Make_SC_Type := null;
-- Set_NOD : Set_NOD_Type := null;
-- Set_NSA : Set_NSA_Type := null;
-- Set_NUA : Set_NUA_Type := null;
-- Set_NUP : Set_NUP_Type := null)
-+ Set_RND : Set_RND_Type := null)
- is
- Text : Source_Buffer_Ptr;
- Hi : Source_Ptr;
-@@ -184,10 +181,7 @@ package body Targparm is
- Source_Last => Hi,
- Make_Id => Make_Id,
- Make_SC => Make_SC,
-- Set_NOD => Set_NOD,
-- Set_NSA => Set_NSA,
-- Set_NUA => Set_NUA,
-- Set_NUP => Set_NUP);
-+ Set_RND => Set_RND);
- end Get_Target_Parameters;
-
- -- Version where caller supplies system.ads text
-@@ -198,10 +192,7 @@ package body Targparm is
- Source_Last : Source_Ptr;
- Make_Id : Make_Id_Type := null;
- Make_SC : Make_SC_Type := null;
-- Set_NOD : Set_NOD_Type := null;
-- Set_NSA : Set_NSA_Type := null;
-- Set_NUA : Set_NUA_Type := null;
-- Set_NUP : Set_NUP_Type := null)
-+ Set_RND : Set_RND_Type := null)
- is
- P : Source_Ptr;
- -- Scans source buffer containing source of system.ads
-@@ -212,48 +203,6 @@ package body Targparm is
- Result : Boolean;
- -- Records boolean from system line
-
-- OK : Boolean;
-- -- Status result from Set_NUP/NSA/NUA call
--
-- PR_Start : Source_Ptr;
-- -- Pointer to ( following pragma Restrictions
--
-- procedure Collect_Name;
-- -- Scan a name starting at System_Text (P), and put Name in Name_Buffer,
-- -- with Name_Len being length, folded to lower case. On return, P points
-- -- just past the last character (which should be a right paren).
--
-- ------------------
-- -- Collect_Name --
-- ------------------
--
-- procedure Collect_Name is
-- begin
-- Name_Len := 0;
-- loop
-- if System_Text (P) in 'a' .. 'z'
-- or else
-- System_Text (P) = '_'
-- or else
-- System_Text (P) in '0' .. '9'
-- then
-- Name_Buffer (Name_Len + 1) := System_Text (P);
--
-- elsif System_Text (P) in 'A' .. 'Z' then
-- Name_Buffer (Name_Len + 1) :=
-- Character'Val (Character'Pos (System_Text (P)) + 32);
--
-- else
-- exit;
-- end if;
--
-- P := P + 1;
-- Name_Len := Name_Len + 1;
-- end loop;
-- end Collect_Name;
--
-- -- Start of processing for Get_Target_Parameters
--
- begin
- if Parameters_Obtained then
- return;
-@@ -312,9 +261,6 @@ package body Targparm is
-
- elsif System_Text (P .. P + 20) = "pragma Restrictions (" then
- P := P + 21;
-- PR_Start := P - 1;
--
-- -- Boolean restrictions
-
- Rloop : for K in All_Boolean_Restrictions loop
- declare
-@@ -339,9 +285,7 @@ package body Targparm is
- null;
- end loop Rloop;
-
-- -- Restrictions taking integer parameter
--
-- Ploop : for K in Integer_Parameter_Restrictions loop
-+ Ploop : for K in All_Parameter_Restrictions loop
- declare
- Rname : constant String :=
- All_Parameter_Restrictions'Image (K);
-@@ -456,119 +400,23 @@ package body Targparm is
- P := P + 1;
- end loop;
-
-- Set_NOD (Unit);
-+ Set_RND (Unit);
- goto Line_Loop_Continue;
- end;
--
-- -- No_Specification_Of_Aspect case
--
-- elsif System_Text (P .. P + 29) = "No_Specification_Of_Aspect => "
-- then
-- P := P + 30;
--
-- -- Skip this processing (and simply ignore the pragma), if
-- -- caller did not supply the subprogram we need to process
-- -- such lines.
--
-- if Set_NSA = null then
-- goto Line_Loop_Continue;
-- end if;
--
-- -- We have scanned
-- -- "pragma Restrictions (No_Specification_Of_Aspect =>"
--
-- Collect_Name;
--
-- if System_Text (P) /= ')' then
-- goto Bad_Restrictions_Pragma;
--
-- else
-- Set_NSA (Name_Find, OK);
--
-- if OK then
-- goto Line_Loop_Continue;
-- else
-- goto Bad_Restrictions_Pragma;
-- end if;
-- end if;
--
-- -- No_Use_Of_Attribute case
--
-- elsif System_Text (P .. P + 22) = "No_Use_Of_Attribute => " then
-- P := P + 23;
--
-- -- Skip this processing (and simply ignore No_Use_Of_Attribute
-- -- lines) if caller did not supply the subprogram we need to
-- -- process such lines.
--
-- if Set_NUA = null then
-- goto Line_Loop_Continue;
-- end if;
--
-- -- We have scanned
-- -- "pragma Restrictions (No_Use_Of_Attribute =>"
--
-- Collect_Name;
--
-- if System_Text (P) /= ')' then
-- goto Bad_Restrictions_Pragma;
--
-- else
-- Set_NUA (Name_Find, OK);
--
-- if OK then
-- goto Line_Loop_Continue;
-- else
-- goto Bad_Restrictions_Pragma;
-- end if;
-- end if;
--
-- -- No_Use_Of_Pragma case
--
-- elsif System_Text (P .. P + 19) = "No_Use_Of_Pragma => " then
-- P := P + 20;
--
-- -- Skip this processing (and simply ignore No_Use_Of_Pragma
-- -- lines) if caller did not supply the subprogram we need to
-- -- process such lines.
--
-- if Set_NUP = null then
-- goto Line_Loop_Continue;
-- end if;
--
-- -- We have scanned
-- -- "pragma Restrictions (No_Use_Of_Pragma =>"
--
-- Collect_Name;
--
-- if System_Text (P) /= ')' then
-- goto Bad_Restrictions_Pragma;
--
-- else
-- Set_NUP (Name_Find, OK);
--
-- if OK then
-- goto Line_Loop_Continue;
-- else
-- goto Bad_Restrictions_Pragma;
-- end if;
-- end if;
- end if;
-
- -- Here if unrecognizable restrictions pragma form
-
-- <<Bad_Restrictions_Pragma>>
--
- Set_Standard_Error;
- Write_Line
- ("fatal error: system.ads is incorrectly formatted");
- Write_Str ("unrecognized or incorrect restrictions pragma: ");
-
-- P := PR_Start;
-+ while System_Text (P) /= ')'
-+ and then
-+ System_Text (P) /= ASCII.LF
- loop
-- exit when System_Text (P) = ASCII.LF;
- Write_Char (System_Text (P));
-- exit when System_Text (P) = ')';
- P := P + 1;
- end loop;
-