summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2017-06-05 16:09:13 +1000
committerRod Kay2017-06-05 16:09:13 +1000
commit8393cbcca0f6ce7688d29b85e379a695689d1292 (patch)
tree06684cc1473c5110493c9809e6dcd6811cf76e58
parent83188d8cfc0194e4555c6c2ef7a3666f5d091785 (diff)
downloadaur-8393cbcca0f6ce7688d29b85e379a695689d1292.tar.gz
Update to latest git version
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD68
-rw-r--r--expose-cargs-and-largs-makefile.patch28
3 files changed, 82 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e56ae2bbeda5..1aca3b3ff1ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,24 @@
# Generated by mksrcinfo v8
-# Mon Mar 6 15:39:47 UTC 2017
-pkgbase = gprbuild
- pkgdesc = Software tool designed to help automate the construction of multi-language systems
- pkgver = 2016
+# Mon Jun 5 04:12:55 UTC 2017
+pkgbase = gprbuild-git
+ pkgdesc = multi-language build system
+ pkgver = r3147.g18e2bc01
pkgrel = 1
url = http://www.adacore.com/gnatpro/toolsuite/gprbuild/
- arch = any
+ arch = i686
+ arch = x86_64
license = GPL
- depends = gcc-ada
- depends = xmlada
- source = http://mirrors.cdn.adacore.com/art/57399662c7a447658e0affa8
- source = Makefile.archy
- sha1sums = c85b877596dbc53bfc39ec5b23f674e8463677ce
- sha1sums = 222357dc7f46b9ab6a8c2df098632c67b4505743
+ makedepends = git
+ makedepends = gprbuild-bootstrap
+ depends = ada-xmlada
+ provides = gprbuild
+ provides = gprbuild-bootstrap
+ conflicts = gprbuild
+ conflicts = gprbuild-bootstrap
+ source = git+https://github.com/AdaCore/gprbuild
+ source = expose-cargs-and-largs-makefile.patch
+ sha1sums = SKIP
+ sha1sums = bda77367bc6985c3daf96929cccf5551a0544237
-pkgname = gprbuild
+pkgname = gprbuild-git
diff --git a/PKGBUILD b/PKGBUILD
index 4fc54d82262f..79ce46973bc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,52 @@
-# Contributor: Sietse van der Molen
-# Contributor: Rod Kay <charlie5 on #ada at freenode.net>
-
-pkgname=gprbuild
-pkgver=2016
+pkgname=gprbuild-git
+pkgver=r3147.g18e2bc01
pkgrel=1
-depends=('gcc-ada' 'xmlada')
-
-pkgdesc="Software tool designed to help automate the construction of multi-language systems"
-
-arch=('any')
+pkgdesc='multi-language build system'
+url='http://www.adacore.com/gnatpro/toolsuite/gprbuild/'
+arch=('i686' 'x86_64')
license=('GPL')
-url="http://www.adacore.com/gnatpro/toolsuite/gprbuild/"
-
-source=("http://mirrors.cdn.adacore.com/art/57399662c7a447658e0affa8"
- "Makefile.archy")
-sha1sums=('c85b877596dbc53bfc39ec5b23f674e8463677ce'
- '222357dc7f46b9ab6a8c2df098632c67b4505743')
+depends=('ada-xmlada')
+makedepends=('git' 'gprbuild-bootstrap')
+# We provide gprbuild-bootstrap here so we can use this gprbuild to bootstrap
+# itself and ada-xmlada.
+provides=('gprbuild' 'gprbuild-bootstrap')
+conflicts=('gprbuild' 'gprbuild-bootstrap')
-prepare()
-{
- WRKSRC=$srcdir/$pkgname-gpl-$pkgver-src
+source=('git+https://github.com/AdaCore/gprbuild'
+ 'expose-cargs-and-largs-makefile.patch')
- cp $srcdir/Makefile.archy ${WRKSRC}
+sha1sums=('SKIP'
+ 'bda77367bc6985c3daf96929cccf5551a0544237')
- cd $pkgname-gpl-$pkgver-src
- mkdir -p obj
+pkgver() {
+ cd gprbuild
+ printf 'r%s.g%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd gprbuild
+ patch -Np1 -i "$srcdir"/expose-cargs-and-largs-makefile.patch
-build()
-{
- cd $pkgname-gpl-$pkgver-src
-
- PREFIX=/usr make -j1 -f Makefile.archy all
+ # Not everyone is Debian
+ sed -i 's/libexec/lib/g' bootstrap.sh doinstall gprbuild.gpr \
+ share/gprconfig/compilers.xml \
+ share/gprconfig/linker.xml \
+ share/gprconfig/gnat.xml
}
+build() {
+ cd gprbuild
+ make prefix=/usr PROCESSORS="$(nproc)" setup
+ make GPRBUILD_OPTIONS=-R
+}
-package()
-{
- cd $pkgname-gpl-$pkgver-src
+package() {
+ cd gprbuild
+ make prefix="$pkgdir"/usr install
- DESTDIR=$pkgdir PREFIX=/usr make -f Makefile.archy install
+ # Cleanup
+ rm -f -- "$pkgdir"/usr/doinstall
}
-
diff --git a/expose-cargs-and-largs-makefile.patch b/expose-cargs-and-largs-makefile.patch
new file mode 100644
index 000000000000..8f5ab3b06ffd
--- /dev/null
+++ b/expose-cargs-and-largs-makefile.patch
@@ -0,0 +1,28 @@
+diff --git a/Makefile b/Makefile
+index b591cb9a..4d711028 100644
+--- a/Makefile
++++ b/Makefile
+@@ -67,6 +67,14 @@ else
+ LIBGPR_TYPES=static
+ endif
+
++ifneq ($(strip $(CFLAGS)),)
++ CARGS := -cargs $(CFLAGS)
++endif
++
++ifneq ($(strip $(LDFLAGS)),)
++ LARGS := -largs $(LDFLAGS)
++endif
++
+ # Used to pass extra options to GPRBUILD, like -d for instance
+ GPRBUILD_OPTIONS=
+
+@@ -75,7 +83,7 @@ LIB_INSTALLER=gprinstall -p -f --target=$(TARGET) $(RBD) --prefix=${prefix}
+ CLEANER=gprclean -q $(RBD)
+
+ GPRBUILD_BUILDER=$(BUILDER) $(GPRBUILD_GPR) \
+- -XLIBRARY_TYPE=static -XXMLADA_BUILD=static
++ -XLIBRARY_TYPE=static -XXMLADA_BUILD=static $(CARGS) $(LARGS)
+ LIBGPR_BUILDER=$(BUILDER) $(GPR_GPR)
+ LIBGPR_INSTALLER=$(LIB_INSTALLER) $(GPR_GPR) -XBUILD=${BUILD} \
+ --install-name=gpr --build-var=LIBRARY_TYPE $(GTARGET)