summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2022-05-14 20:13:24 +0200
committerXiretza2022-05-14 20:13:24 +0200
commit8afe996328c5da54cdcd7181ccb534218f2ab32f (patch)
tree9aaeb039a0c42c6ac421ece71ce8659ce128b598
parent35a02ae8d5f57af6faeed98448dae7f5a4d1e2a6 (diff)
downloadaur-8afe996328c5da54cdcd7181ccb534218f2ab32f.tar.gz
Update patches
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Makefile-build-relocatable-instead-of-static-binarie.patch25
-rw-r--r--0001-compilers.xml-use-gcc-version-to-get-version-number-.patch (renamed from 0002-compilers.xml-use-gcc-version-to-get-version-number-.patch)6
-rw-r--r--0002-Makefile-always-use-host-gprinstall.patch30
-rw-r--r--PKGBUILD22
-rw-r--r--always-use-host-gprinstall.patch11
-rw-r--r--relocatable-build.patch11
7 files changed, 74 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a506a80555b..3a38079b17dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,14 +12,14 @@ pkgbase = gprbuild
makedepends = xmlada
source = gprbuild-22.0.0.tar.gz::https://github.com/AdaCore/gprbuild//archive/v22.0.0.tar.gz
source = gprconfig_kb-22.0.0.tar.gz::https://github.com/AdaCore/gprconfig_kb/archive/v22.0.0.tar.gz
- source = relocatable-build.patch
- source = always-use-host-gprinstall.patch
- source = 0002-compilers.xml-use-gcc-version-to-get-version-number-.patch
+ source = 0001-Makefile-build-relocatable-instead-of-static-binarie.patch
+ source = 0002-Makefile-always-use-host-gprinstall.patch
+ source = 0001-compilers.xml-use-gcc-version-to-get-version-number-.patch
sha256sums = 076e2b6ac0c7170753a6499094a6d30a98698aca2551c6796b3a617dd9ffc704
sha256sums = cc19437e0982d9af31e09ad7c42eac6a445dac65336bd53d67ba61f630be7f13
- sha256sums = d6479e03e6b6cfb09c133d94e3c47ea5d5e5e756b95554ab3106a679c3d57de4
- sha256sums = 3fe0fd1df3156c9a8488d98ee6e7e822ae904ce410838661c8fc14c29abe2620
- sha256sums = 9aa8cd9e522fb8a39b2512698885016db1b7286d8fe87d35bdc92e1bc10b20b7
+ sha256sums = 6ebbea41d4b8b516d0646438338fb228ea907600a2ad2c594bab41a7e1c3680c
+ sha256sums = bcb0887eacce9ae609676c1965425847ab4fb27c5a5689f625c1864caeac8ad3
+ sha256sums = 42c66c412eb2e4949a754d660b04b77395d40d54b26a933ef7c75c5881e94238
pkgname = libgpr
pkgdesc = Ada library to handle Gnat project files
diff --git a/0001-Makefile-build-relocatable-instead-of-static-binarie.patch b/0001-Makefile-build-relocatable-instead-of-static-binarie.patch
new file mode 100644
index 000000000000..69ab3b8dc359
--- /dev/null
+++ b/0001-Makefile-build-relocatable-instead-of-static-binarie.patch
@@ -0,0 +1,25 @@
+From eda322bdea193e59ae45bdd3e94c078ec0f25962 Mon Sep 17 00:00:00 2001
+From: Xiretza <xiretza@xiretza.xyz>
+Date: Sun, 23 Jan 2022 13:05:53 +0100
+Subject: [PATCH 1/2] Makefile: build relocatable instead of static binaries
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 2239c1df..d0750332 100644
+--- a/Makefile
++++ b/Makefile
+@@ -78,7 +78,7 @@ LIB_INSTALLER=gprinstall -p -f --target=$(TARGET) $(RBD) "--prefix=${prefix}"
+ CLEANER=gprclean -q $(RBD)
+
+ GPRBUILD_BUILDER=$(BUILDER) $(GPRBUILD_GPR) \
+- -XLIBRARY_TYPE=static -XXMLADA_BUILD=static
++ -XLIBRARY_TYPE=relocatable -XXMLADA_BUILD=relocatable
+ LIBGPR_BUILDER=$(BUILDER) $(GPR_GPR)
+ LIBGPR_INSTALLER=$(LIB_INSTALLER) $(GPR_GPR) -XBUILD=${BUILD} \
+ --install-name=gpr \
+--
+2.34.1
+
diff --git a/0002-compilers.xml-use-gcc-version-to-get-version-number-.patch b/0001-compilers.xml-use-gcc-version-to-get-version-number-.patch
index 6dfa210d32c8..82f858a2a48f 100644
--- a/0002-compilers.xml-use-gcc-version-to-get-version-number-.patch
+++ b/0001-compilers.xml-use-gcc-version-to-get-version-number-.patch
@@ -1,7 +1,7 @@
-From 9853bdb0b04ec8cd28483b127699ebd9cb305a77 Mon Sep 17 00:00:00 2001
+From 9dc1dc5559ae72026c8d33fed1e74c9612782b44 Mon Sep 17 00:00:00 2001
From: Xiretza <xiretza@xiretza.xyz>
Date: Sat, 4 Dec 2021 19:47:58 +0100
-Subject: [PATCH 2/2] compilers.xml: use gcc --version to get version number
+Subject: [PATCH] compilers.xml: use gcc --version to get version number
instead of gcc -v
The output of gcc -v is dependent on locale can thus break the regex.
@@ -12,7 +12,7 @@ See also https://github.com/AdaCore/gprconfig_kb/issues/10
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/db/compilers.xml b/db/compilers.xml
-index ac9a701..416329a 100644
+index f8909d2..eee25a2 100644
--- a/db/compilers.xml
+++ b/db/compilers.xml
@@ -22,9 +22,9 @@
diff --git a/0002-Makefile-always-use-host-gprinstall.patch b/0002-Makefile-always-use-host-gprinstall.patch
new file mode 100644
index 000000000000..1082ff84472c
--- /dev/null
+++ b/0002-Makefile-always-use-host-gprinstall.patch
@@ -0,0 +1,30 @@
+From c51a3fa53e4b13e8adcead066e59c2b464fd697f Mon Sep 17 00:00:00 2001
+From: Xiretza <xiretza@xiretza.xyz>
+Date: Sun, 23 Jan 2022 13:02:56 +0100
+Subject: [PATCH 2/2] Makefile: always use host gprinstall
+
+By default, the Makefile tries to use the freshly-built gprinstall to
+install itself - but since that binary required libgpr, which we are
+currently building, this can't work.
+
+Simply fall back to gprbuild-bootstrap's statically linked gprinstall.
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index d0750332..85b7cca4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -40,7 +40,7 @@ LIB_DIR = lib/
+ # target options for cross-build
+ ifeq ($(HOST),$(TARGET))
+ GTARGET=
+-INSTALLER=exe/$(BUILD)/$(LIB_INSTALLER)
++INSTALLER=$(LIB_INSTALLER)
+ else
+ GTARGET=--target=$(TARGET)
+ INSTALLER=$(LIB_INSTALLER)
+--
+2.34.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 21de007bd180..47b2ef213a75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,27 +17,25 @@ makedepends=('gprbuild-bootstrap' 'xmlada')
source=(
"$pkgbase-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
"gprconfig_kb-$pkgver.tar.gz::https://github.com/AdaCore/gprconfig_kb/archive/v$pkgver.tar.gz"
- "relocatable-build.patch"
- "always-use-host-gprinstall.patch"
- "0002-compilers.xml-use-gcc-version-to-get-version-number-.patch"
+ '0001-Makefile-build-relocatable-instead-of-static-binarie.patch'
+ '0002-Makefile-always-use-host-gprinstall.patch'
+ '0001-compilers.xml-use-gcc-version-to-get-version-number-.patch'
)
sha256sums=('076e2b6ac0c7170753a6499094a6d30a98698aca2551c6796b3a617dd9ffc704'
'cc19437e0982d9af31e09ad7c42eac6a445dac65336bd53d67ba61f630be7f13'
- 'd6479e03e6b6cfb09c133d94e3c47ea5d5e5e756b95554ab3106a679c3d57de4'
- '3fe0fd1df3156c9a8488d98ee6e7e822ae904ce410838661c8fc14c29abe2620'
- '9aa8cd9e522fb8a39b2512698885016db1b7286d8fe87d35bdc92e1bc10b20b7')
+ '6ebbea41d4b8b516d0646438338fb228ea907600a2ad2c594bab41a7e1c3680c'
+ 'bcb0887eacce9ae609676c1965425847ab4fb27c5a5689f625c1864caeac8ad3'
+ '42c66c412eb2e4949a754d660b04b77395d40d54b26a933ef7c75c5881e94238')
prepare() {
cd "$srcdir/gprconfig_kb-$pkgver"
- patch -Np1 -i "$srcdir/0002-compilers.xml-use-gcc-version-to-get-version-number-.patch"
+ patch -Np1 -i "$srcdir/0001-compilers.xml-use-gcc-version-to-get-version-number-.patch"
cd "$srcdir/$pkgbase-$pkgver"
- patch -Np1 -i "$srcdir/relocatable-build.patch"
- # By default, it tries to use the freshly-built gprinstall to install gprbuild, but that requires libgpr,
- # which can't be installed yet. Simply fall back to gprinstall from gprbuild-bootstrap
- patch -Np1 -i "$srcdir/always-use-host-gprinstall.patch"
+ patch -Np1 -i "$srcdir/0001-Makefile-build-relocatable-instead-of-static-binarie.patch"
+ patch -Np1 -i "$srcdir/0002-Makefile-always-use-host-gprinstall.patch"
ln -sfT "$srcdir/gprconfig_kb-$pkgver/db/" "share/gprconfig"
@@ -105,4 +103,4 @@ package_gprbuild() {
rm -f -- "$pkgdir/usr/doinstall"
}
-# vim: set et ts=4: \ No newline at end of file
+# vim: set et ts=4:
diff --git a/always-use-host-gprinstall.patch b/always-use-host-gprinstall.patch
deleted file mode 100644
index fbbad280b5fd..000000000000
--- a/always-use-host-gprinstall.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile 2020-05-21 18:07:25.521090704 +0200
-+++ b/Makefile 2020-05-21 18:07:45.827341018 +0200
-@@ -40,7 +40,7 @@
- # target options for cross-build
- ifeq ($(HOST),$(TARGET))
- GTARGET=
--INSTALLER=exe/$(BUILD)/$(LIB_INSTALLER)
-+INSTALLER=$(LIB_INSTALLER)
- else
- GTARGET=--target=$(TARGET)
- INSTALLER=$(LIB_INSTALLER)
diff --git a/relocatable-build.patch b/relocatable-build.patch
deleted file mode 100644
index d6f7db3dd8cc..000000000000
--- a/relocatable-build.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -78,7 +78,7 @@
- CLEANER=gprclean -q $(RBD)
-
- GPRBUILD_BUILDER=$(BUILDER) $(GPRBUILD_GPR) \
-- -XLIBRARY_TYPE=static -XXMLADA_BUILD=static
-+ -XLIBRARY_TYPE=relocatable -XXMLADA_BUILD=relocatable
- LIBGPR_BUILDER=$(BUILDER) $(GPR_GPR)
- LIBGPR_INSTALLER=$(LIB_INSTALLER) $(GPR_GPR) -XBUILD=${BUILD} \
- --install-name=gpr \