summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2017-06-05 15:05:56 +1000
committerRod Kay2017-06-05 15:05:56 +1000
commit2d27ed53f4f1f862ac83f6ee0e4ffba00023e130 (patch)
tree9b2704883042c5fa3de5a2a9c67d596aa3e94d2e
downloadaur-2d27ed53f4f1f862ac83f6ee0e4ffba00023e130.tar.gz
Add initial files
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD48
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61ec72f2aea3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Mon Jun 5 05:05:29 UTC 2017
+pkgbase = gprbuild-bootstrap
+ pkgdesc = static gprbuild to bootstrap xmlada and gprbuild proper
+ pkgver = r3147.g18e2bc01
+ pkgrel = 1
+ url = http://www.adacore.com/gnatpro/toolsuite/gprbuild/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = gcc-ada
+ depends = glibc
+ provides = gprbuild-bootstrap
+ conflicts = gprbuild
+ conflicts = gprbuild-bootstrap
+ options = debug
+ options = !strip
+ source = git+https://github.com/AdaCore/gprbuild
+ source = git+https://github.com/AdaCore/xmlada
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = gprbuild-bootstrap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d97a7c987884
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+pkgname=gprbuild-bootstrap
+pkgver=r3147.g18e2bc01
+pkgrel=1
+
+pkgdesc='static gprbuild to bootstrap xmlada and gprbuild proper'
+url='http://www.adacore.com/gnatpro/toolsuite/gprbuild/'
+arch=('i686' 'x86_64')
+license=('GPL')
+
+options=('debug' '!strip')
+
+depends=('glibc')
+makedepends=('git' 'gcc-ada')
+
+provides=('gprbuild-bootstrap')
+conflicts=('gprbuild' 'gprbuild-bootstrap')
+
+source=('git+https://github.com/AdaCore/gprbuild'
+ 'git+https://github.com/AdaCore/xmlada')
+
+sha1sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd gprbuild
+ printf 'r%s.g%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd gprbuild
+
+ # Not everyone is Debian.
+ sed -i 's/libexec/lib/g' doinstall gprbuild.gpr \
+ share/gprconfig/compilers.xml \
+ share/gprconfig/linker.xml \
+ share/gprconfig/gnat.xml
+}
+
+build() {
+ cd gprbuild
+ export GNATMAKEFLAGS="-j$(nproc)"
+ export DESTDIR="$srcdir"/bootstrap
+ ./bootstrap.sh --prefix=/usr --libexecdir=/lib --with-xmlada="$srcdir"/xmlada
+}
+
+package() {
+ cd bootstrap
+ cp -a --no-preserve=ownership -- "$srcdir"/bootstrap/usr "$pkgdir"
+}