summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2021-06-21 16:41:48 +1000
committerRod Kay2021-06-21 16:41:48 +1000
commit63822b3556319de16b37376512bd6a567e5c00cb (patch)
treeaf377a2a5f7cf49ea3dae9347f262a5c3aa2aef6
parent772d08b19f129cef2baf4425fcc040be4e1b184f (diff)
downloadaur-63822b3556319de16b37376512bd6a567e5c00cb.tar.gz
Install licenses.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1af610b0c656..17eeebdc85dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = gprbuild-bootstrap
pkgdesc = Static GPRbuild to bootstrap XML/Ada and GPRbuild itself
pkgver = 21.0.0
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://github.com/AdaCore/gprbuild/
arch = i686
arch = x86_64
license = GPL3
+ license = custom
depends = gcc-ada
source = gprbuild-21.0.0.tar.gz::https://github.com/AdaCore/gprbuild/archive/v21.0.0.tar.gz
source = xmlada-21.0.0.tar.gz::https://github.com/AdaCore/xmlada/archive/v21.0.0.tar.gz
@@ -16,4 +17,3 @@ pkgbase = gprbuild-bootstrap
sha256sums = 2aec26afad5bb1a4685d9c041c9c797ff5beda211a5e81f2a97452d2ceabc557
pkgname = gprbuild-bootstrap
-
diff --git a/PKGBUILD b/PKGBUILD
index 93da3fcc7f67..a6246e15782f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,11 @@
pkgname=gprbuild-bootstrap
epoch=1
pkgver=21.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Static GPRbuild to bootstrap XML/Ada and GPRbuild itself"
arch=('i686' 'x86_64')
url='https://github.com/AdaCore/gprbuild/'
-license=('GPL3')
+license=('GPL3' 'custom')
depends=('gcc-ada')
source=(
@@ -52,6 +52,16 @@ package() {
--prefix=/usr \
--libexecdir=/lib \
--install
+
+ # Install the license.
+ install -D -m644 \
+ "COPYING3" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING3"
+
+ # Install the custom license.
+ install -D -m644 \
+ "COPYING.RUNTIME" \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME"
}
# vim: set et ts=4: