summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Marie de Rodat2017-06-17 12:08:38 +0200
committerPierre-Marie de Rodat2017-06-18 12:34:20 +0200
commit673951a752d84a7c9fb07db4c190431888a8f6f7 (patch)
treefed30f2cc8844e2d04ef555f1a62386810662835
downloadaur-673951a752d84a7c9fb07db4c190431888a8f6f7.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD51
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20060b821089
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gprbuild-bootstrap-git
+ pkgdesc = Static GPRbuild to bootstrap XML/Ada and GPRbuild itself
+ pkgver = r3152.ba7dba01
+ pkgrel = 1
+ url = https://github.com/AdaCore/gprbuild/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = gcc-ada
+ depends = glibc
+ provides = gprbuild
+ conflicts = gprbuild
+ source = git+https://github.com/AdaCore/gprbuild.git
+ source = git+https://github.com/AdaCore/xmlada.git
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = gprbuild-bootstrap-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..16c2359580b4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+gprbuild
+pkg
+src
+xmlada
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4f26373ae7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Pierre-Marie de Rodat <pmderodat on #ada at freenode.net>
+# Contributor: Rod Kay <charlie5 on #ada at freenode.net>
+pkgname=gprbuild-bootstrap-git
+pkgver=r3152.ba7dba01
+pkgrel=1
+pkgdesc="Static GPRbuild to bootstrap XML/Ada and GPRbuild itself"
+arch=('i686' 'x86_64')
+url='https://github.com/AdaCore/gprbuild/'
+license=('GPL3')
+depends=('glibc')
+makedepends=('git' 'gcc-ada')
+provides=('gprbuild')
+conflicts=('gprbuild')
+source=('git+https://github.com/AdaCore/gprbuild.git'
+ 'git+https://github.com/AdaCore/xmlada.git')
+sha1sums=(SKIP SKIP)
+
+
+pkgver() {
+ cd "$srcdir/gprbuild"
+ printf "r%s.%s" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/gprbuild"
+
+ # GPRbuild hard-codes references to /usr/libexec, but ArchLinux packages
+ # must use /usr/lib instead.
+ sed -i 's/libexec/lib/g' doinstall gprbuild.gpr \
+ share/gprconfig/compilers.xml \
+ share/gprconfig/linker.xml \
+ share/gprconfig/gnat.xml
+}
+
+build() {
+ cd "$srcdir/gprbuild"
+
+ export GNATMAKEFLAGS="-j$(nproc)"
+ export DESTDIR="$srcdir/bootstrap"
+ ./bootstrap.sh \
+ --prefix=/usr \
+ --libexecdir=/lib \
+ --with-xmlada="$srcdir/xmlada"
+}
+
+package() {
+ cd "$srcdir/bootstrap"
+ cp -a --no-preserve=ownership -- "$srcdir/bootstrap/usr" "$pkgdir"
+}