summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Marie de Rodat2021-05-24 08:13:51 +0200
committerPierre-Marie de Rodat2021-05-24 08:13:51 +0200
commit7b3cecbe36f0c4a5a0ac489a588a1ac08ae1f139 (patch)
tree6fae4d15de3586c65cfd1f5fd9be64314dfed73e
parent3d412a6d16a1b454f69915a9e8a883110f7c6a68 (diff)
downloadaur-gprbuild-git.tar.gz
Remove the workaround for -gnat2020 now that Arch uses GCC 11
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--gnat2020.patch26
3 files changed, 2 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecb32ce58eb8..c956282a35ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gprbuild-git
pkgdesc = Builder for multi-language systems
- pkgver = r3723.815226d6
+ pkgver = r3779.5e603a95
pkgrel = 1
url = https://github.com/AdaCore/gprbuild/
arch = i686
@@ -11,13 +11,11 @@ pkgbase = gprbuild-git
makedepends = xmlada
source = git+https://github.com/AdaCore/gprbuild.git
source = git+https://github.com/AdaCore/gprconfig_kb.git
- source = gnat2020.patch
source = relocatable-build.patch
source = always-use-host-gprinstall.patch
source = expose-cargs-and-largs-makefile.patch
sha1sums = SKIP
sha1sums = SKIP
- sha1sums = 683f8a6b5e7da3ba5bef3f7f40bcf6054527696b
sha1sums = 91b20bde99cf02410cdb2b74aa1adb014458a9b3
sha1sums = 66792ebc73aff76a368bd902adc6a6f181d1d878
sha1sums = 85c3e5facda8ce8316955a501ef56086f1c41bc0
diff --git a/PKGBUILD b/PKGBUILD
index 643b2af3065a..3c5416bb563b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Earnestly <zibeon AT googlemail.com>
pkgbase=gprbuild-git
pkgname=(libgpr-git gprbuild-git)
-pkgver=r3723.815226d6
+pkgver=r3779.5e603a95
pkgrel=1
pkgdesc="Builder for multi-language systems"
arch=('i686' 'x86_64')
@@ -14,13 +14,11 @@ makedepends=('git' 'gprbuild-bootstrap' 'xmlada')
source=('git+https://github.com/AdaCore/gprbuild.git'
'git+https://github.com/AdaCore/gprconfig_kb.git'
- 'gnat2020.patch'
'relocatable-build.patch'
'always-use-host-gprinstall.patch'
'expose-cargs-and-largs-makefile.patch')
sha1sums=('SKIP'
'SKIP'
- '683f8a6b5e7da3ba5bef3f7f40bcf6054527696b'
'91b20bde99cf02410cdb2b74aa1adb014458a9b3'
'66792ebc73aff76a368bd902adc6a6f181d1d878'
'85c3e5facda8ce8316955a501ef56086f1c41bc0')
@@ -37,10 +35,6 @@ prepare() {
patch -Np1 -i "$srcdir/expose-cargs-and-largs-makefile.patch"
patch -Np1 -i "$srcdir/relocatable-build.patch"
- # Do not pass the "-gnat2020" flag. This is necessary with GCC 10, which
- # has buggy support for Ada 2020. TODO: remove this once GCC 11 is out.
- patch -Np1 -i "$srcdir/gnat2020.patch"
-
# By default, it tries to use the freshly-built gprinstall to install
# gprbuild, but that requires libgpr, which can't be installed yet. Simply
# fall back to gprinstall from gprbuild-bootstrap.
diff --git a/gnat2020.patch b/gnat2020.patch
deleted file mode 100644
index 970d7efb3223..000000000000
--- a/gnat2020.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/gpr/gpr.gpr b/gpr/gpr.gpr
-index 7ff9ff81..98180a3e 100644
---- a/gpr/gpr.gpr
-+++ b/gpr/gpr.gpr
-@@ -43,7 +43,7 @@ library project GPR is
- --------------
-
- package Compiler is
-- Common_Switches := ("-gnat2020", "-gnaty", "-gnatQ", "-gnata");
-+ Common_Switches := ("-gnaty", "-gnatQ", "-gnata");
-
- case Bld is
- when "debug" =>
-diff --git a/gprbuild.gpr b/gprbuild.gpr
-index 0fa1df76..35e04535 100644
---- a/gprbuild.gpr
-+++ b/gprbuild.gpr
-@@ -81,7 +81,7 @@ project Gprbuild is
- --------------
-
- package Compiler is
-- Common_Switches := ("-gnat2020", "-gnaty", "-gnatQ", "-gnata", "-gnateE");
-+ Common_Switches := ("-gnaty", "-gnatQ", "-gnata", "-gnateE");
-
- case Bld is
- when "debug" =>