summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Marie de Rodat2018-03-10 18:33:29 +0100
committerPierre-Marie de Rodat2018-03-10 18:34:19 +0100
commit619e1f5b67713ec03ca51c50c96c5463a129d9e8 (patch)
tree2f32d431d7f210ca7abdce24a7ee39281e8ccf5f
parent4fe6e36d87e229653a894dd43bb0a74a18c8ba5e (diff)
downloadaur-619e1f5b67713ec03ca51c50c96c5463a129d9e8.tar.gz
Switch build mode to "production"
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62acdbf3088a..2ea672fc314e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gprbuild-git
pkgdesc = Build system for multi-language systems
- pkgver = r3152.ba7dba01
+ pkgver = r3307.832b1ce6
pkgrel = 1
url = https://github.com/AdaCore/gprbuild/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 71dc51b4ad94..2b1588b8d2f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Rod Kay <charlie5 on #ada at freenode.net>
# Contributor: Earnestly <zibeon AT googlemail.com>
pkgname=gprbuild-git
-pkgver=r3152.ba7dba01
+pkgver=r3307.832b1ce6
pkgrel=1
pkgdesc="Build system for multi-language systems"
arch=('i686' 'x86_64')
@@ -43,8 +43,8 @@ prepare() {
build() {
cd "$srcdir/${pkgname%-git}"
- make prefix=/usr PROCESSORS="$(nproc)" setup
- make GPRBUILD_OPTIONS=-R
+ make prefix=/usr BUILD=production PROCESSORS="$(nproc)" setup
+ make GPRBUILD_OPTIONS=-R BUILD=production
}
package() {
@@ -52,7 +52,7 @@ package() {
# Make one install at a time to avoid GPRinstall reading/writing to
# the same installed project files at the same time.
- make prefix="$pkgdir/usr" install -j1
+ make prefix="$pkgdir/usr" install -j1 BUILD=production
# We don't need to distribute the installation script
rm -f -- "$pkgdir/usr/doinstall"