summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2020-05-21 14:54:26 +0200
committerPierre-Marie de Rodat2020-06-13 12:34:25 +0200
commit914e938379576ed26a313a4d898872b27a4154da (patch)
tree62dc19ac855050e73404091360b459891ffb1c84
parent619e1f5b67713ec03ca51c50c96c5463a129d9e8 (diff)
downloadaur-914e938379576ed26a313a4d898872b27a4154da.tar.gz
Update patches
-rw-r--r--PKGBUILD8
-rw-r--r--expose-cargs-and-largs-makefile.patch69
-rw-r--r--relocatable-build.patch4
3 files changed, 62 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b1588b8d2f4..055b19a67d9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Rod Kay <charlie5 on #ada at freenode.net>
# Contributor: Earnestly <zibeon AT googlemail.com>
pkgname=gprbuild-git
-pkgver=r3307.832b1ce6
+pkgver=r3601.cf5c323f
pkgrel=1
-pkgdesc="Build system for multi-language systems"
+pkgdesc="Builder for multi-language systems"
arch=('i686' 'x86_64')
url="https://github.com/AdaCore/gprbuild/"
license=('GPL3')
@@ -18,8 +18,8 @@ source=('git+https://github.com/AdaCore/gprbuild.git'
'relocatable-build.patch'
'expose-cargs-and-largs-makefile.patch')
sha1sums=('SKIP'
- '4aaab0df8b611750d2cb35973ed28823fb233989'
- 'db88bcb65d1a5f41c5b30e0c3dea996c47c4f5b9')
+ '91b20bde99cf02410cdb2b74aa1adb014458a9b3'
+ 'ddaf20842ed9879c3f1cb24b3eb7615d5cfe61a5')
pkgver() {
cd "$srcdir/${pkgname%-git}"
diff --git a/expose-cargs-and-largs-makefile.patch b/expose-cargs-and-largs-makefile.patch
index 113a29a9bd7b..5021c9d78aec 100644
--- a/expose-cargs-and-largs-makefile.patch
+++ b/expose-cargs-and-largs-makefile.patch
@@ -1,28 +1,71 @@
-diff --git a/Makefile b/Makefile
-index b591cb9a..4d711028 100644
--- a/Makefile
+++ b/Makefile
-@@ -67,6 +67,14 @@ else
+@@ -70,6 +70,14 @@
LIBGPR_TYPES=static
endif
+ifneq ($(strip $(CFLAGS)),)
-+ CARGS := -cargs $(CFLAGS)
++ TOOLFLAGS += -cargs $(CFLAGS)
+endif
+
+ifneq ($(strip $(LDFLAGS)),)
-+ LARGS := -largs $(LDFLAGS)
++ TOOLFLAGS += -largs $(LDFLAGS)
+endif
+
# Used to pass extra options to GPRBUILD, like -d for instance
GPRBUILD_OPTIONS=
-@@ -75,7 +83,7 @@ LIB_INSTALLER=gprinstall -p -f --target=$(TARGET) $(RBD) --prefix=${prefix}
- CLEANER=gprclean -q $(RBD)
+@@ -92,27 +100,27 @@
+ .PHONY: all distall gprbuild gprconfig gprclean gprinstall gprname gprls
+
+ build all:
+- $(GPRBUILD_BUILDER)
++ $(GPRBUILD_BUILDER) $(TOOLFLAGS)
+
+ distall: all install
+
+ gprbuild:
+- $(GPRBUILD_BUILDER) gprbuild-main.adb
++ $(GPRBUILD_BUILDER) gprbuild-main.adb $(TOOLFLAGS)
+
+ gprinstall:
+- $(GPRBUILD_BUILDER) gprinstall-main.adb
++ $(GPRBUILD_BUILDER) gprinstall-main.adb $(TOOLFLAGS)
+
+ gprclean:
+- $(GPRBUILD_BUILDER) gprclean-main.adb
++ $(GPRBUILD_BUILDER) gprclean-main.adb $(TOOLFLAGS)
+
+ gprconfig:
+- $(GPRBUILD_BUILDER) gprconfig-main.adb
++ $(GPRBUILD_BUILDER) gprconfig-main.adb $(TOOLFLAGS)
+
+ gprname:
+- $(GPRBUILD_BUILDER) gprname-main.adb
++ $(GPRBUILD_BUILDER) gprname-main.adb $(TOOLFLAGS)
+
+ gprls:
+- $(GPRBUILD_BUILDER) gprls-main.adb
++ $(GPRBUILD_BUILDER) gprls-main.adb $(TOOLFLAGS)
+
+ #################################
+ # Gprbuild installation targets #
+@@ -140,15 +148,15 @@
+
+ libgpr.build.shared:
+ ${BUILDER} -XLIBRARY_TYPE=relocatable \
+- -XXMLADA_BUILD=relocatable $(GPR_GPR)
++ -XXMLADA_BUILD=relocatable $(GPR_GPR) $(TOOLFLAGS)
+
+ libgpr.build.static:
+ ${BUILDER} -XLIBRARY_TYPE=static \
+- -XXMLADA_BUILD=static $(GPR_GPR)
++ -XXMLADA_BUILD=static $(GPR_GPR) $(TOOLFLAGS)
+
+ libgpr.build.static-pic:
+ ${BUILDER} -XLIBRARY_TYPE=static-pic \
+- -XXMLADA_BUILD=static-pic $(GPR_GPR)
++ -XXMLADA_BUILD=static-pic $(GPR_GPR) $(TOOLFLAGS)
+
+ libgpr.install: libgpr.uninstall $(foreach t, $(LIBGPR_TYPES), libgpr.install.$(t))
- GPRBUILD_BUILDER=$(BUILDER) $(GPRBUILD_GPR) \
-- -XLIBRARY_TYPE=relocatable -XXMLADA_BUILD=relocatable
-+ -XLIBRARY_TYPE=relocatable -XXMLADA_BUILD=relocatable $(CARGS) $(LARGS)
- LIBGPR_BUILDER=$(BUILDER) $(GPR_GPR)
- LIBGPR_INSTALLER=$(LIB_INSTALLER) $(GPR_GPR) -XBUILD=${BUILD} \
- --install-name=gpr --build-var=LIBRARY_TYPE $(GTARGET)
diff --git a/relocatable-build.patch b/relocatable-build.patch
index 0ed02e6ba1a9..d6f7db3dd8cc 100644
--- a/relocatable-build.patch
+++ b/relocatable-build.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -75,7 +75,7 @@
+@@ -78,7 +78,7 @@
CLEANER=gprclean -q $(RBD)
GPRBUILD_BUILDER=$(BUILDER) $(GPRBUILD_GPR) \
@@ -8,4 +8,4 @@
+ -XLIBRARY_TYPE=relocatable -XXMLADA_BUILD=relocatable
LIBGPR_BUILDER=$(BUILDER) $(GPR_GPR)
LIBGPR_INSTALLER=$(LIB_INSTALLER) $(GPR_GPR) -XBUILD=${BUILD} \
- --install-name=gpr --build-var=LIBRARY_TYPE $(GTARGET)
+ --install-name=gpr \