summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorent H. CARRÉ2015-07-19 01:35:40 +0200
committerFlorent H. CARRÉ2015-07-19 01:35:40 +0200
commit29d8055f53f8e01901e2dead58b3d2002b50d1e3 (patch)
tree65a898c587d45f75291783ef08cd850c609d247d
downloadaur-29d8055f53f8e01901e2dead58b3d2002b50d1e3.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3290b44a6a61
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gprof2dot
+ pkgdesc = A Python script to convert the output from many profilers into a dot graph.
+ pkgver = 2015.02.03
+ pkgrel = 1
+ url = http://jrfonseca.googlecode.com/
+ arch = any
+ license = LGPL
+ makedepends = git
+ depends = python
+ provides = gprof2dot
+ source = https://pypi.python.org/packages/source/g/gprof2dot/gprof2dot-2015.02.03.tar.gz
+ md5sums = b026772f1cc8f7f203143855e0316443
+
+pkgname = gprof2dot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc0e351fd3f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer : Florent H. CARRÉ <colundrum@gmail.com>
+
+pkgname=gprof2dot
+pkgver=2015.02.03
+pkgrel=1
+pkgdesc="A Python script to convert the output from many profilers into a dot graph."
+arch=("any")
+url="http://jrfonseca.googlecode.com/"
+license=('LGPL')
+depends=(python)
+makedepends=('git')
+provides=(gprof2dot)
+source=("https://pypi.python.org/packages/source/g/gprof2dot/gprof2dot-$pkgver.tar.gz")
+md5sums=('b026772f1cc8f7f203143855e0316443')
+build() {
+cd "$srcdir/gprof2dot-$pkgver"
+python setup.py build
+# move this "old" version out of the way
+#mv "$pkgdir/usr/bin/smiley" "$pkgdir/usr/bin/smiley2"
+# should report this upstream as still not fixed...
+#sed -i "s|#!/usr/bin/env python$|#!/usr/bin/env python2|" \
+#$pkgdir/usr/lib/python2.7/site-packages/smiley.py
+
+}
+package() {
+cd "$srcdir/gprof2dot-$pkgver"
+python setup.py install --prefix=/usr --root="$pkgdir"
+}