summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2017-06-20 23:31:09 +0000
committerBalló György2017-06-20 23:31:09 +0000
commit338e602ce59e247d418835d19f61a92d4ab365e6 (patch)
tree116a38ddec93939dbbc71f2bcb0748fee6da2439
downloadaur-338e602ce59e247d418835d19f61a92d4ab365e6.tar.gz
upgpkg: gps-share 0.1.0-1
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52d833580a2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gps-share
+ pkgdesc = Utility to share your GPS device on local network
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/zeenix/gps-share
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = cargo
+ makedepends = systemd
+ depends = dbus
+ source = gps-share-0.1.0.tar.gz::https://github.com/zeenix/gps-share/archive/0.1.0.tar.gz
+ sha256sums = 3af9f03d2be9c55a6f21e1d2360ced00e980d301e54525cf8d9b29ddc426a10e
+
+pkgname = gps-share
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6532c678860
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id$
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=gps-share
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Utility to share your GPS device on local network"
+arch=('x86_64' 'i686')
+url="https://github.com/zeenix/gps-share"
+license=('GPL')
+depends=('dbus')
+makedepends=('cargo' 'systemd')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/zeenix/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('3af9f03d2be9c55a6f21e1d2360ced00e980d301e54525cf8d9b29ddc426a10e')
+
+build() {
+ cd $pkgname-$pkgver
+ cargo build --release
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 target/release/gps-share "$pkgdir/usr/bin/gps-share"
+}