summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbernhard2015-08-18 22:55:04 +0200
committerbernhard2015-08-18 22:55:04 +0200
commitec3ec7143a441578ab21bb1d2a2eb4a256eb428c (patch)
treecb70b482edeedd3308d4dde82af307cd9ffe917d
downloadaur-ec3ec7143a441578ab21bb1d2a2eb4a256eb428c.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86ee2377e39a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gpscorrelate-git
+ pkgdesc = GPS Photo Correlation; Writes location data to EXIF tags using GPX files (command line and GTK interface).
+ pkgver = r68.365f6e1
+ pkgrel = 1
+ url = https://github.com/freefoote/gpscorrelate
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = libxml2
+ depends = gtk2
+ depends = exiv2
+ source = git+https://github.com/freefoote/gpscorrelate
+ sha256sums = SKIP
+
+pkgname = gpscorrelate-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5775c82ff4a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Hinrich Harms <arch@hinrich.de>
+# Contributor: sylvain alborini <sylvain.alborini@gmail.com>
+# Maintainer: John Wallaby <drunken.wallaby@gmail.com>
+
+_pkgname=gpscorrelate
+pkgname=gpscorrelate-git
+pkgver=r68.365f6e1
+pkgrel=1
+pkgdesc='GPS Photo Correlation; Writes location data to EXIF tags using GPX files (command line and GTK interface).'
+url='https://github.com/freefoote/gpscorrelate'
+license=('GPL')
+source=('git+https://github.com/freefoote/gpscorrelate')
+sha256sums=('SKIP')
+arch=('any')
+depends=('libxml2' 'gtk2' 'exiv2')
+makedepends=('git')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Get the version number.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $srcdir/${_pkgname}
+ make prefix=/usr DESTDIR=$pkgdir install || return 1
+}
+
+
+# vim: ft=sh ts=2 sw=2 et