summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergej Pupykin2016-02-05 21:05:15 +0300
committerSergej Pupykin2016-02-05 21:05:15 +0300
commita226569f9cd0ceb2842aa956ec3c62608d8c9990 (patch)
treedf53c8253cee607685df4e48f5a4c52edc596a44
downloadaur-gpsdrive.tar.gz
removed from community
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD76
-rw-r--r--gpsd-3.14.patch20
-rw-r--r--gpsdrive-perltovendor.patch28
-rw-r--r--gpsdrive.install4
5 files changed, 174 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1749ba59ccfc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+# Generated by mksrcinfo v8
+# Fri Feb 5 18:04:44 UTC 2016
+pkgbase = gpsdrive
+ pkgdesc = A car (bike, ship, plane) navigation system
+ pkgver = 2.11
+ pkgrel = 32
+ url = http://www.gpsdrive.de/
+ install = gpsdrive.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake>=2.4.4
+ makedepends = boost
+ makedepends = cfitsio
+ depends = gtk2
+ depends = gpsd
+ depends = libxml2
+ depends = curl
+ depends = python2
+ depends = boost-libs
+ depends = gdal
+ depends = mapnik
+ depends = postgresql-libs
+ depends = openstreetmap-map-icons-svn
+ depends = perl-date-manip
+ depends = perl-timedate
+ depends = perl-dbi
+ depends = perl-file-slurp
+ depends = perl-www-mechanize
+ depends = perl-libwww
+ depends = perl-uri
+ depends = perl-text-query
+ depends = perl-www-curl
+ depends = perl-xml-parser
+ depends = perl-xml-simple
+ depends = perl-xml-twig
+ depends = perl-xml-writer
+ source = http://arch.p5n.pp.ru/~sergej/dl/2015/gpsdrive-20150407.tar.xz
+ source = gpsdrive-perltovendor.patch
+ source = gpsd-3.14.patch
+ md5sums = c363e751ba1e70e49b198a1889142ca5
+ md5sums = c28bc2dc51a76a39161bf540aebfab6c
+ md5sums = 77fa3d6b0437cff54505aedde7ab7230
+
+pkgname = gpsdrive
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a9135324269
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# $Id: PKGBUILD 154188 2015-12-22 11:46:52Z bpiotrowski $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Maintainer: damir <damir@archlinux.org>
+
+pkgname=gpsdrive
+pkgver=2.11
+_pkgver=20150407
+pkgrel=32
+pkgdesc="A car (bike, ship, plane) navigation system"
+arch=("i686" "x86_64")
+url="http://www.gpsdrive.de/"
+license=('GPL2')
+depends=('gtk2' 'gpsd' 'libxml2' 'curl' 'python2' 'boost-libs' 'gdal' 'mapnik' 'postgresql-libs' 'openstreetmap-map-icons-svn'
+ 'perl-date-manip' 'perl-timedate' 'perl-dbi' 'perl-file-slurp' 'perl-www-mechanize' 'perl-libwww' 'perl-uri'
+ 'perl-text-query' 'perl-www-curl' 'perl-xml-parser' 'perl-xml-simple' 'perl-xml-twig' 'perl-xml-writer')
+makedepends=('cmake>=2.4.4' 'boost' 'cfitsio')
+install="gpsdrive.install"
+#source=("http://www.gpsdrive.de/packages/${pkgname}-${pkgver}.tar.gz")
+source=("http://arch.p5n.pp.ru/~sergej/dl/2015/${pkgname}-${_pkgver}.tar.xz"
+ "gpsdrive-perltovendor.patch"
+ "gpsd-3.14.patch")
+md5sums=('c363e751ba1e70e49b198a1889142ca5'
+ 'c28bc2dc51a76a39161bf540aebfab6c'
+ '77fa3d6b0437cff54505aedde7ab7230')
+
+prepare() {
+ cd "$srcdir"
+ # python2 fix
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_#!/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' $file
+ done
+ sed -i 's|GdkGC \*kontext_map;|extern GdkGC *kontext_map;|' $srcdir/gpsdrive-${_pkgver}/src/gpsdrive.c
+ sed -i '22,1i#include <mapnik/graphics.hpp>' $srcdir/gpsdrive-${_pkgver}/src/mapnik.cpp
+ sed -i 's|datasource_cache::instance()->|datasource_cache::instance().|' $srcdir/gpsdrive-${_pkgver}/src/mapnik.cpp
+ cd gpsdrive-${_pkgver}
+ patch -p1 <$srcdir/gpsdrive-perltovendor.patch
+ patch -p1 <$srcdir/gpsd-3.14.patch
+}
+
+build() {
+ cd "$srcdir"
+
+ mkdir -p build
+ cd build
+
+ export CFLAGS=-I/usr/include/gdk-pixbuf-2.0/
+ export CPPFLAGS=-I/usr/include/gdk-pixbuf-2.0/
+ export CXXFLAGS=-I/usr/include/gdk-pixbuf-2.0/
+ export LDFLAGS="`pkg-config --libs gtk+-2.0 gmodule-2.0` -lboost_system -lboost_thread"
+
+ # see DefineOptions.cmake for a list of common options and defaults
+ # cmake -L for a more in-depth listing
+ cmake -DCMAKE_BUILD_TYPE=Debug -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DWITH_SCRIPTS=ON \
+ -DWITH_MAPNIK=ON \
+ -DWITH_POSTGIS=ON \
+ -DWITH_GDAL=ON \
+ -DWITH_BASEMAPS=ON \
+ -DWITH_FRIENDSD=ON \
+ -DWITH_KISMET=ON \
+ -DWITH_NAVIGATION=ON \
+ -DWITH_SPEECH=OFF \
+ -DWITH_DBUS=OFF \
+ -DLIBGPS_OLD=OFF \
+ -DFREETYPE2_INCLUDE_DIRS=/usr/include/freetype2 \
+ -DFREETYPE2_LIBRARIES=/usr/lib \
+ "$srcdir/gpsdrive-${_pkgver}"
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/gpsd-3.14.patch b/gpsd-3.14.patch
new file mode 100644
index 000000000000..21246d4341cd
--- /dev/null
+++ b/gpsd-3.14.patch
@@ -0,0 +1,20 @@
+diff -wbBur gpsdrive-20150407/src/gps_handler.c gpsdrive-20150407.q/src/gps_handler.c
+--- gpsdrive-20150407/src/gps_handler.c 2015-04-07 14:39:04.000000000 +0300
++++ gpsdrive-20150407.q/src/gps_handler.c 2015-05-22 14:40:05.036450732 +0300
+@@ -443,11 +443,11 @@
+ for (i=0;i<data->satellites;i++)
+ #endif
+ {
+- gps_sats[i].used = data->used[i];
+- gps_sats[i].prn = data->PRN[i];
+- gps_sats[i].elevation = data->elevation[i];
+- gps_sats[i].azimuth = data->azimuth[i];
+- gps_sats[i].snr = data->ss[i];
++ gps_sats[i].used = data->skyview[i].used;
++ gps_sats[i].prn = data->skyview[i].PRN;
++ gps_sats[i].elevation = data->skyview[i].elevation;
++ gps_sats[i].azimuth = data->skyview[i].azimuth;
++ gps_sats[i].snr = data->skyview[i].ss;
+ }
+ }
+
diff --git a/gpsdrive-perltovendor.patch b/gpsdrive-perltovendor.patch
new file mode 100644
index 000000000000..c89226761f62
--- /dev/null
+++ b/gpsdrive-perltovendor.patch
@@ -0,0 +1,28 @@
+diff -ru gpsdrive-2.11/scripts/osm/perl_lib/CMakeLists.txt gpsdrive-2.11-patched/scripts/osm/perl_lib/CMakeLists.txt
+--- gpsdrive-2.11/scripts/osm/perl_lib/CMakeLists.txt 2010-06-24 15:53:32.000000000 -0400
++++ gpsdrive-2.11-patched/scripts/osm/perl_lib/CMakeLists.txt 2014-06-11 18:50:59.000000000 -0400
+@@ -5,10 +5,10 @@
+ MACRO_OPTIONAL_FIND_PACKAGE(Perl)
+
+ if (PERL_FOUND)
+- if (NOT PERL_SITELIB)
++ if (NOT PERL_VENDORLIB)
+ MACRO_OPTIONAL_FIND_PACKAGE(PerlLibs)
+- endif (NOT PERL_SITELIB)
+- #MESSAGE("DEBUG: > PERL_SITELIB: ${PERL_SITELIB}")
++ endif (NOT PERL_VENDORLIB)
++ #MESSAGE("DEBUG: > PERL_VENDORLIB: ${PERL_VENDORLIB}")
+
+ file(GLOB_RECURSE perl_modules ${CMAKE_CURRENT_SOURCE_DIR}/*.pm)
+
+@@ -16,8 +16,8 @@
+ foreach(perl_module ${perl_modules})
+ file(RELATIVE_PATH relative_module_path ${CMAKE_CURRENT_SOURCE_DIR} ${perl_module})
+ get_filename_component(relative_module_path ${relative_module_path} PATH)
+- install(FILES ${perl_module} DESTINATION ${PERL_SITELIB}/${relative_module_path})
+- #message("DEBUG: install ${perl_module} to ${PERL_SITELIB}/${relative_module_path}")
++ install(FILES ${perl_module} DESTINATION ${PERL_VENDORLIB}/${relative_module_path})
++ #message("DEBUG: install ${perl_module} to ${PERL_VENDORLIB}/${relative_module_path}")
+ endforeach(perl_module ${perl_modules})
+ endif (perl_modules)
+ endif (PERL_FOUND)
diff --git a/gpsdrive.install b/gpsdrive.install
new file mode 100644
index 000000000000..8ea63912e76b
--- /dev/null
+++ b/gpsdrive.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Don't forget to generate geoinfo.db with geoinfo.pl script"
+ echo "Also you can check http://wiki.archlinux.org/index.php/GpsDrive"
+}