summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Markus2020-08-17 19:25:36 +0200
committerTobias Markus2020-08-17 19:25:36 +0200
commit4554f57c41cc0e58c31b4bfb274bd3eade4f51d4 (patch)
tree85fe4fff0fd0700799cf9c168f8c04b0625d6401
downloadaur-4554f57c41cc0e58c31b4bfb274bd3eade4f51d4.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8dadce63034d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gpstk
+ pkgdesc = Algorithms and frameworks supporting the development of processing and analysis applications in navigation and global positioning
+ pkgver = 2.12.1
+ pkgrel = 1
+ url = http://www.gpstk.org
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ provides = gpstk
+ conflicts = gpstk
+ source = https://gitlab.com/sgl-ut/GPSTk/-/archive/v2.12.1/GPSTk-v2.12.1.tar.gz
+ sha256sums = 0c4442126654857a424584263c9f6a40871c492fc98f7b59bf7122051a2d9dba
+
+pkgname = gpstk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa8899b33c48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Tobias Markus < tobias AT miglix DOT eu >
+# Contributor: Samuel Mesa <samuelmesa@linuxmail.org>
+
+pkgname=gpstk
+pkgver=2.12.1
+pkgrel=1
+pkgdesc="Algorithms and frameworks supporting the development of processing and analysis applications in navigation and global positioning"
+url="http://www.gpstk.org"
+license=('LGPL')
+depends=()
+makedepends=('cmake')
+provides=('gpstk')
+conflicts=('gpstk')
+arch=('x86_64')
+source=("https://gitlab.com/sgl-ut/GPSTk/-/archive/v${pkgver}/GPSTk-v${pkgver}.tar.gz")
+sha256sums=('0c4442126654857a424584263c9f6a40871c492fc98f7b59bf7122051a2d9dba')
+
+build() {
+ cd "${srcdir}"
+
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS} -Wno-deprecated"
+ cmake -B build \
+ -S "GPSTk-v${pkgver}" \
+ -Wno-dev \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=None \
+ -DUSE_RPATH=OFF
+
+ make -C build
+}
+
+package() {
+ cd "${srcdir}"
+
+ make -C build DESTDIR="${pkgdir}" install
+}