summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Gustaw2023-03-19 21:34:01 +0900
committerDaniel Gustaw2023-03-19 21:34:01 +0900
commit5566c613fee487099cc8952d524b4e0a630de880 (patch)
treec044469ea181f6c3b8309d2c829f998ce6cbae66
parent72e1c299d3d9ee61cdfa51992f1a2ce78f8c2395 (diff)
downloadaur-5566c613fee487099cc8952d524b4e0a630de880.tar.gz
pkgbuild cleanup
-rw-r--r--PKGBUILD35
1 files changed, 6 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 21ee02986538..9ce6a23cb963 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,40 +4,17 @@ pkgrel=1
pkgdesc="Run linux commands with natural language. Eg.: 'show my graphic card' instead 'lspci | grep VGA'"
arch=('x86_64')
url="https://github.com/gustawdaniel/gpt-cli"
+license=('MIT')
depends=('xorg-server-devel' 'libxcb')
options=()
source_x86_64=("https://github.com/gustawdaniel/gpt-cli/releases/download/v0.0.14/gpt-cli")
sha512sums_x86_64=('b9653478daf24af90c35634c94d40cc8c1cb735137a44fdbad33264c90d2ea0051c658e86c719fab72dd461899e93caf72cde06d8c1b4127e9589e5176686a9f')
-package(){
- ls ${pkgdir}
- # Extract package data
-# tar xf data.tar.xz -C "${pkgdir}"
-# install -D -m644 "${pkgdir}/opt/InfinityWallet/resources/app.asar.unpacked/node_modules/phantomjs-prebuilt/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
-
-post_install() {
-# gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- cp gpt-cli /usr/local/bin/gpt-cli
- # Link to the binary
- ln -s /usr/local/bin/p /usr/local/bin/gpt-cli
+package() {
+ # Install the binary
+ install -Dm755 "$srcdir/gpt-cli" "$pkgdir/usr/bin/gpt-cli"
- # SUID chrome-sandbox for Electron 5+
-# chmod 4755 '/opt/InfinityWallet/chrome-sandbox' || true
-
- update-mime-database /usr/share/mime || true
- update-desktop-database /usr/share/applications || true
- update-desktop-database -q
+ # Create a symbolic link
+ ln -s "/usr/bin/gpt-cli" "$pkgdir/usr/bin/p"
}
-post_upgrade() {
- post_install
-}
-
-post_remove() {
-# gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-
- # Delete the link to the binary
- rm -f '/usr/local/bin/p' /usr/local/bin/gpt-cli
- update-desktop-database -q
-}