summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Muñoz2024-04-04 16:32:35 -0500
committerKevin Muñoz2024-04-04 16:32:35 -0500
commit16398d19f9bea8e25f5643679b8fa977ae676086 (patch)
tree32e5430d083e3f15870ba602e6039c62abaaebde
downloadaur-16398d19f9bea8e25f5643679b8fa977ae676086.tar.gz
Initial upload
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD39
-rw-r--r--gpt-telegramus.service15
4 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e537c53f7a49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gpt-telegramus-git
+ pkgdesc = GPT-Telegramus is a Telegram bot that allows you to interact with various large language models (LLMs), including ChatGPT, Bing AI (also known as Sidney or EdgeGPT), and Gemini.
+ pkgver = 5.2.5.r0.g4ace3864
+ pkgrel = 1
+ url = https://github.com/F33RNI/GPT-Telegramus
+ arch = any
+ license = AGPL-3.0-only
+ depends = python
+ depends = python-virtualenv
+ depends = bash
+ provides = GPT-Telegramus
+ backup = opt/gpt-telegramus/config.json
+ source = GPT-Telegramus::git+https://github.com/F33RNI/GPT-Telegramus.git
+ source = gpt-telegramus.service
+ validpgpkeys = 2B9D22B41F2AF1042BFCE73A3CA0B9DF1BE7CE09
+ sha256sums = SKIP
+ sha256sums = 248424fe9c6d049786befbee00ebc270189d8afe16a2a4190d3cd127b3874156
+
+pkgname = gpt-telegramus-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9efe578af12f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.pkg.tar.zst.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b44fb8ee7210
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: MrHacker <david.munozm@proton.me>
+_pkgname=GPT-Telegramus
+pkgname=gpt-telegramus-git
+pkgver=5.2.5.r0.g4ace3864
+pkgrel=1
+pkgdesc="GPT-Telegramus is a Telegram bot that allows you to interact with various large language models (LLMs), including ChatGPT, Bing AI (also known as Sidney or EdgeGPT), and Gemini."
+url="https://github.com/F33RNI/GPT-Telegramus"
+arch=(any)
+license=('AGPL-3.0-only')
+depends=(
+ 'python'
+ 'python-virtualenv'
+ 'bash'
+ )
+provides=("$_pkgname")
+backup=(
+ "opt/gpt-telegramus/config.json"
+ )
+source=(
+ "${_pkgname}::git+https://github.com/F33RNI/$_pkgname.git"
+ "gpt-telegramus.service"
+)
+validpgpkeys=(
+ '2B9D22B41F2AF1042BFCE73A3CA0B9DF1BE7CE09' #MrHacker GPGKey
+)
+sha256sums=('SKIP'
+ '248424fe9c6d049786befbee00ebc270189d8afe16a2a4190d3cd127b3874156')
+
+
+package() {
+ mkdir -p "$pkgdir/opt"
+ cd "$_pkgname"
+ cp -r . "$pkgdir/opt/gpt-telegramus"
+ cd ..
+ install -Dm644 "gpt-telegramus.service" "$pkgdir/usr/lib/systemd/system/gpt-telegramus.service"
+ cd "$pkgdir/opt/gpt-telegramus"
+ chmod +x run.sh
+ python -m venv venv
+}
diff --git a/gpt-telegramus.service b/gpt-telegramus.service
new file mode 100644
index 000000000000..aa9295f39e84
--- /dev/null
+++ b/gpt-telegramus.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=GPT-Telegramus service
+After=multi-user.target
+
+[Service]
+Type=simple
+Restart=on-failure
+RestartSec=5
+
+WorkingDirectory=/opt/gpt-telegramus
+ExecStart=/opt/gpt-telegramus/run.sh
+
+[Install]
+WantedBy=multi-user.target
+