summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2021-07-11 15:45:37 +0200
committerMuflone2021-07-11 15:45:37 +0200
commit144796621514ba01e31f3fbef1976908e9f7b709 (patch)
tree8ecfeee91276584bbdc68ac9b05e1d990064ad62
parented5b22320733851437f03681d704f9bb0120cd44 (diff)
downloadaur-144796621514ba01e31f3fbef1976908e9f7b709.tar.gz
Updated package gptrace 0.5.0-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD15
-rw-r--r--gptrace.install14
3 files changed, 15 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13a52e5e6115..3b469ae0e310 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = gptrace
pkgdesc = Trace the activities of an external application
- pkgver = 0.4.2
+ pkgver = 0.5.0
pkgrel = 1
- url = http://www.muflone.com/gptrace/
- install = gptrace.install
+ url = https://www.muflone.com/gptrace/
arch = any
- license = GPL2
+ license = GPL
depends = gtk3
depends = gobject-introspection
- depends = python2-xdg
- depends = python2-gobject
- depends = python2-ptrace
- depends = gtk-update-icon-cache
- source = gptrace-0.4.2.tar.gz::https://github.com/muflone/gptrace/archive/0.4.2.tar.gz
- sha256sums = 3dfe39680e3e10beedee89a095c231d53efca74c0b6a79703f547b9287566b89
+ depends = python-xdg
+ depends = python-gobject
+ depends = python-ptrace
+ source = gptrace-0.5.0.tar.gz::https://github.com/muflone/gptrace/archive/0.5.0.tar.gz
+ sha256sums = 0c0f6c6098f8d49324b81bf3b5393ccadfe935e698b30c70b8b8985f97a1b942
pkgname = gptrace
-
diff --git a/PKGBUILD b/PKGBUILD
index 368504422af2..1244fec8a875 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Muflone http://www.muflone.com/contacts/english/
pkgname=gptrace
-pkgver=0.4.2
+pkgver=0.5.0
pkgrel=1
pkgdesc="Trace the activities of an external application"
-url="http://www.muflone.com/gptrace/"
+url="https://www.muflone.com/gptrace/"
arch=('any')
-license=('GPL2')
-depends=('gtk3' 'gobject-introspection' 'python2-xdg' 'python2-gobject' 'python2-ptrace' 'gtk-update-icon-cache')
+license=('GPL')
+depends=('gtk3' 'gobject-introspection' 'python-xdg' 'python-gobject' 'python-ptrace')
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/muflone/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('3dfe39680e3e10beedee89a095c231d53efca74c0b6a79703f547b9287566b89')
-install="${pkgname}.install"
+sha256sums=('0c0f6c6098f8d49324b81bf3b5393ccadfe935e698b30c70b8b8985f97a1b942')
build() {
cd "${pkgname}-${pkgver}"
- python2 setup.py build
+ python setup.py build
}
package() {
cd "${pkgname}-${pkgver}"
- python2 setup.py install --optimize=1 --root "${pkgdir}"
+ python setup.py install --optimize=1 --root "${pkgdir}"
}
diff --git a/gptrace.install b/gptrace.install
deleted file mode 100644
index a02985b5a2db..000000000000
--- a/gptrace.install
+++ /dev/null
@@ -1,14 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q /usr/share/icons/hicolor/
- xdg-icon-resource forceupdate
- xdg-desktop-menu forceupdate
-}
-
-post_update() {
- post_install
-}
-
-post_remove() {
- post_install
-}
-