summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:17 +0200
committerMuflone2015-06-13 17:59:17 +0200
commit1eb2754c3d9f628501baef7763622e2b6d67a89f (patch)
tree9dcbae9f6be3c583e24f4a80e95399a65f41c8e8
downloadaur-1eb2754c3d9f628501baef7763622e2b6d67a89f.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
-rw-r--r--gptrace-git.install14
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..303ac0896023
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = gptrace-git
+ pkgdesc = Trace the activities of an external application
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = http://www.muflone.com/gptrace/
+ install = gptrace-git.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = gtk3
+ depends = gobject-introspection
+ depends = python2-xdg
+ depends = python2-gobject
+ depends = python2-ptrace
+ depends = gtk-update-icon-cache
+ provides = gptrace
+ conflicts = gptrace
+ source = git+https://github.com/muflone/gptrace.git
+ sha256sums = SKIP
+
+pkgname = gptrace-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb8509898c94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=gptrace-git
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Trace the activities of an external application"
+url="http://www.muflone.com/gptrace/"
+arch=('any')
+license=('GPL2')
+depends=('gtk3' 'gobject-introspection' 'python2-xdg' 'python2-gobject' 'python2-ptrace' 'gtk-update-icon-cache')
+makedepends=('git')
+provides=('gptrace')
+conflicts=('gptrace')
+source=("git+https://github.com/muflone/gptrace.git")
+sha256sums=('SKIP')
+install="${pkgname}.install"
+
+pkgver() {
+ cd "${pkgname%-*}"
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd "${pkgname%-*}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${pkgname%-*}"
+ python2 setup.py install --optimize=1 --root "${pkgdir}"
+}
+
diff --git a/gptrace-git.install b/gptrace-git.install
new file mode 100644
index 000000000000..a02985b5a2db
--- /dev/null
+++ b/gptrace-git.install
@@ -0,0 +1,14 @@
+post_install() {
+ gtk-update-icon-cache -q /usr/share/icons/hicolor/
+ xdg-icon-resource forceupdate
+ xdg-desktop-menu forceupdate
+}
+
+post_update() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+