summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Schoenick2019-08-29 17:54:55 -0700
committerJohn Schoenick2019-08-29 17:54:55 -0700
commitd9cf4857364845fe3ad6a0f9145445a2a015c17c (patch)
tree86397a6200458bb74097d00dfef676bfbaf1bcb2
downloadaur-d9cf4857364845fe3ad6a0f9145445a2a015c17c.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e241bf30de5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Aug 30 00:54:45 UTC 2019
+pkgbase = amdgpu-trace-git
+ pkgdesc = Trace capture helper for amdgpu based systems
+ pkgver = v1.1.r1.g47551c6
+ pkgrel = 1
+ url = https://github.com/lostgoat/amdgpu-trace
+ arch = x86_64
+ license = MIT
+ depends = gpuvis-git
+ depends = trace-cmd
+ provides = amdgpu-trace
+ conflicts = amdgpu-trace
+ source = git+https://github.com/lostgoat/amdgpu-trace
+ sha256sums = SKIP
+
+pkgname = amdgpu-trace-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85222a65cffb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Andres Rodriguez <andresx7@gmail.com>
+
+pkgname=amdgpu-trace-git
+pkgver=v1.1.r1.g47551c6
+pkgrel=1
+pkgdesc="Trace capture helper for amdgpu based systems"
+arch=('x86_64')
+url="https://github.com/lostgoat/amdgpu-trace"
+license=('MIT')
+depends=('gpuvis-git' 'trace-cmd')
+provides=('amdgpu-trace')
+conflicts=('amdgpu-trace')
+source=("git+$url")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/amdgpu-trace"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/amdgpu-trace"
+ install -dm755 "$pkgdir/usr/bin/"
+ make INSTALL_PATH="$pkgdir/usr/" install
+}