summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh2020-01-21 14:00:18 -0800
committerJosh2020-01-21 14:00:18 -0800
commit06166ec3807cfea2ab31511b523338b2a1968d46 (patch)
treeafbd19afce7bd69b483f90be9247fed801adaa14
parenta54be6a979cabfbcca50402dab78be1bdec42530 (diff)
downloadaur-06166ec3807cfea2ab31511b523338b2a1968d46.tar.gz
Need the CUDA kernel file in the right place
Signed-off-by: Josh <josh.farwell@gmail.com>
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 808357fd6e21..198a62271fcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,6 +13,9 @@ sha256sums=('SKIP')
prepare () {
sed -i "s|CUDAPATH=/usr/local/cuda|CUDAPATH=/opt/cuda|g" "$pkgname"/Makefile
+
+ # Hax to make the program pick up compare.ctx in /usr/lib
+ sed -i 's|const char \*kernelFile = "compare.ptx"|const char \*kernelFile = "/usr/lib/gpu_burn/compare.ptx"|g' "$pkgname"/gpu_burn-drv.cpp
}
build () {
@@ -22,5 +25,6 @@ build () {
package() {
cd "$srcdir/$pkgname"
- install -Dm755 gpu_burn "${pkgdir}/usr/bin/gpu_burn"
+ install -Dm755 gpu_burn "${pkgdir}"/usr/bin/gpu_burn
+ install -Dm644 compare.ptx "${pkgdir}"/usr/lib/gpu_burn/compare.ptx
}