summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh2020-01-21 13:33:38 -0800
committerJosh2020-01-21 13:39:53 -0800
commita54be6a979cabfbcca50402dab78be1bdec42530 (patch)
treef490697cbe04e7b978a7dd1eaa46bdf9373d647b
downloadaur-a54be6a979cabfbcca50402dab78be1bdec42530.tar.gz
initial commit
Signed-off-by: Josh <josh.farwell@gmail.com>
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab0269f49746
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gpu_burn-git
+ pkgdesc = Multi-GPU CUDA stress test
+ pkgver = 0.9.35cfc40
+ pkgrel = 1
+ url = https://github.com/wilicc/gpu-burn
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = nvidia
+ depends = opencl-nvidia
+ depends = cuda
+ source = gpu_burn-git::git+https://github.com/wilicc/gpu-burn?ref=35cfc4045d8435ffac20035bab31e8c412aa1cb4
+ sha256sums = SKIP
+
+pkgname = gpu_burn-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..808357fd6e21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: sparklespdx <josh.farwell@gmail.com>
+pkgname="gpu_burn-git"
+pkgver=0.9.35cfc40
+pkgrel=1
+pkgdesc="Multi-GPU CUDA stress test"
+arch=('x86_64')
+url="https://github.com/wilicc/gpu-burn"
+license=('BSD')
+makedepends=('git')
+depends=('nvidia' 'opencl-nvidia' 'cuda')
+source=("${pkgname}::git+https://github.com/wilicc/gpu-burn?ref=35cfc4045d8435ffac20035bab31e8c412aa1cb4")
+sha256sums=('SKIP')
+
+prepare () {
+ sed -i "s|CUDAPATH=/usr/local/cuda|CUDAPATH=/opt/cuda|g" "$pkgname"/Makefile
+}
+
+build () {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 gpu_burn "${pkgdir}/usr/bin/gpu_burn"
+}