summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhoumaster2018-01-14 17:52:43 +0100
committerhoumaster2018-01-14 17:52:43 +0100
commit0f029f22c9d3cd1b5071d851db95d33dfdec73ff (patch)
treeee7cb078fa5c3acffae2e1d1743814dca23d008a
downloadaur-0f029f22c9d3cd1b5071d851db95d33dfdec73ff.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cdbc919ba5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gpupad-git
+ pkgdesc = A text editor for efficiently editing GLSL shaders of all kinds.
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/houmaster/gpupad
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = qbs
+ makedepends = git
+ depends = qt5-declarative
+ provides = gpupad
+ conflicts = gpupad
+ source = git+https://github.com/houmaster/gpupad.git
+ md5sums = SKIP
+
+pkgname = gpupad-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a963b68af0a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+
+pkgname=gpupad-git
+_pkgname=gpupad
+pkgver=latest
+pkgrel=1
+pkgdesc='A text editor for efficiently editing GLSL shaders of all kinds.'
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/houmaster/gpupad"
+license=('GPL3')
+depends=('qt5-declarative')
+makedepends=('qbs' 'git')
+conflicts=(${_pkgname})
+provides=(${_pkgname})
+source=('git+https://github.com/houmaster/gpupad.git')
+md5sums=(SKIP)
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ echo "\"${pkgver}\"" > "src/_version.h"
+ qbs setup-qt /usr/bin/qmake qt5
+ qbs build -d "../${pkgname}-build" profile:qt5 release
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ qbs install -d "../${pkgname}-build" --no-build --install-root "${pkgdir}/usr" profile:qt5 release
+}