summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwift Geek2014-09-06 00:00:11 +0000
committerKyle Keen2014-09-06 00:00:11 +0000
commitede544acfac7f5e32669e37e707b0193f22c7f2e (patch)
tree497ad972ea9f6e751badf2a0ab036555c96790e4
parent4a5f557c0a8c635f2db50b8f27ff2609baec90f7 (diff)
downloadaur-ede544acfac7f5e32669e37e707b0193f22c7f2e.tar.gz
Import from pkgbuild.com service
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD32
-rwxr-xr-xgputest.sh40
4 files changed, 77 insertions, 21 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..653d865fc34d
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = gputest
+ pkgdesc = cross-platform GPU stress test and OpenGL benchmark. Contains FurMark, TessMark
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = http://www.geeks3d.com/gputest/
+ arch = x86_64
+ license = custom:freeware
+ makedepends = unzip
+ depends = gcc-libs
+ depends = mesa
+ optdepends = python2: tkinter gui
+ optdepends = tk: tkinter gui
+ source = http://www.ozone3d.net/gputest/dl/GpuTest_Linux_x64_0.7.0.zip
+ source = gputest.sh
+
+pkgname = gputest
+
diff --git a/.SRCINFO b/.SRCINFO
index 1731f65c7fa6..4ce61b0f5cf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,19 @@
pkgbase = gputest
pkgdesc = cross-platform GPU stress test and OpenGL benchmark. Contains FurMark, TessMark
pkgver = 0.7.0
- pkgrel = 0
+ pkgrel = 1
url = http://www.geeks3d.com/gputest/
arch = x86_64
license = custom:freeware
makedepends = unzip
+ depends = gcc-libs
+ depends = mesa
+ optdepends = python2: tkinter gui
+ optdepends = tk: tkinter gui
+ source = http://www.ozone3d.net/gputest/dl/GpuTest_Linux_x64_0.7.0.zip
+ source = gputest.sh
md5sums = 54bdaa11c73fa08f2e0a47d639f4bdb8
+ md5sums = SKIP
pkgname = gputest
diff --git a/PKGBUILD b/PKGBUILD
index 772d6dcb2a76..a40af76a762a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,31 @@
# Maintainer: Swift Geek <swifgeek ɐ google m č0m>
# Contributor: Nick Østergaard <oe.nick at gmail dot com>
+DLAGENTS=('http::/usr/bin/curl -e "http://www.geeks3d.com/20131028/gputest-0-6-0-opengl-benchmark-for-windows-mac-os-x-and-linux-downloads/" -fLC - --retry 3 --retry-delay 3 -o %o %u')
pkgname=gputest
pkgver=0.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="cross-platform GPU stress test and OpenGL benchmark. Contains FurMark, TessMark"
arch=('x86_64')
url="http://www.geeks3d.com/gputest/"
license=('custom:freeware')
-depends=()
+depends=(gcc-libs mesa) # multilib?
+optdepends=('python2: tkinter gui'
+ 'tk: tkinter gui')
makedepends=('unzip')
-#source=("http://www.ozone3d.net/gputest/dl/GpuTest_Linux_x64_${pkgver}.zip")
-#noextract=("GpuTest_Linux_x64_${pkgver}.zip")
-md5sums=('54bdaa11c73fa08f2e0a47d639f4bdb8')
+source=("http://www.ozone3d.net/gputest/dl/GpuTest_Linux_x64_${pkgver}.zip" 'gputest.sh')
+md5sums=('54bdaa11c73fa08f2e0a47d639f4bdb8' 'SKIP')
prepare() {
- cd $srcdir
- # Fetch
- echo $md5s
- wget -c --referer "http://www.geeks3d.com/20131028/gputest-0-6-0-opengl-benchmark-for-windows-mac-os-x-and-linux-downloads/" \
- "http://www.ozone3d.net/gputest/dl/GpuTest_Linux_x64_${pkgver}.zip"
- echo ${md5sums[0]} GpuTest_Linux_x64_${pkgver}.zip | md5sum -c --quiet
- rm -rf "$srcdir/gputest"
- mkdir "$srcdir/gputest"
- cd "$srcdir/gputest"
- unzip "$srcdir/GpuTest_Linux_x64_${pkgver}.zip"
-
- cd "$srcdir/gputest/GpuTest_Linux_x64_${pkgver}"
+ cd "$srcdir/GpuTest_Linux_x64_${pkgver}"
sed -i '2icd /opt/gputest/' *.sh
sed -i 's#./GpuTest#/opt/gputest/GpuTest#' ./gputest_gui.py
- sed -i '1s"^#!.\+$"#!/usr/bin/python2"' ./gputest_gui.py
-
+# sed -i '1s"^#!.\+$"#!/usr/bin/python2"' ./gputest_gui.py # They deleted that with 0.7
+ sed -i '1s".*"#!/usr/bin/python2"' ./gputest_gui.py
}
package () {
- cd "$srcdir/gputest/GpuTest_Linux_x64_${pkgver}"
+ cd "$srcdir/GpuTest_Linux_x64_${pkgver}"
install -d "$pkgdir/usr/share/licenses/$pkgname/"
cp "./EULA.txt" "$pkgdir/usr/share/licenses/$pkgname/"
install -d "$pkgdir/opt/gputest/data/"
@@ -44,4 +35,5 @@ package () {
install -m 644 ./data/.DS_Store "$pkgdir/opt/gputest/data/"
install -d "$pkgdir/usr/bin/"
install -m 755 {*.sh,*.py} "$pkgdir/usr/bin/"
+ install -m 755 ${srcdir}/gputest.sh "$pkgdir/usr/bin/gputest"
}
diff --git a/gputest.sh b/gputest.sh
new file mode 100755
index 000000000000..4f4ac11808fa
--- /dev/null
+++ b/gputest.sh
@@ -0,0 +1,40 @@
+#!/bin/bash
+
+#TODO: change /args to gnu ones in this wrapper, -h if will need -h$
+
+for ARGV in $@ ; do
+ if [[ $ARGV == *'-h'* ]]; then
+ cat <<HELP
+GpuTest 0.7.0 usage (AUR wrapper, no warranty nor support)
+ -h --help This message
+ /fullscreen
+ /gpumon_terminal # always passed by gui
+ /width=XRES
+ /height=YRES
+ /test=DEMO
+ /benchmark
+ /print_score # was used together with benchmark
+ /submit_gpudb
+ /user_screen_name # name for submit?
+
+Demos:
+ fur some_desc and urls copy&paste
+ tess_x8
+ tess_x16
+ tess_x32
+ tess_x64
+ gi
+ pixmark_julia_fp32
+ pixmark_julia_fp64
+ pixmark_piano
+ pixmark_volplosion
+ plot3d
+ triangle (Default)
+HELP
+ exit 0
+ fi
+done
+
+cd /opt/gputest
+exec ./GpuTest "$@"
+