summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2019-05-08 10:30:28 +0100
committerEric Engestrom2019-05-08 10:35:01 +0100
commita0b7ce7194b3d5d285f96623c90c36449c6fc890 (patch)
treeeff79ace3a20368ebd0211605a68d887a624fc01
parentdd6a40681288804a1fe7318829d80f5fc9808682 (diff)
downloadaur-a0b7ce7194b3d5d285f96623c90c36449c6fc890.tar.gz
bump with a bunch of hacky fixes to make it build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
-rw-r--r--fix.diff58
3 files changed, 78 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 389f682658e9..beabdcdb6617 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = gpuvis-git
- pkgver = r859.5b8f4bc
+ pkgver = r1639.a138c1cf40c23830d49c
pkgrel = 1
url = https://github.com/mikesart/gpuvis
arch = x86_64
license = MIT
source = https://github.com/mikesart/gpuvis
+ source = fix.diff
sha1sums = SKIP
+ sha1sums = 12ad046b5d470ce133e21993498949e48a192553
pkgname = gpuvis-git
diff --git a/PKGBUILD b/PKGBUILD
index 7410ae048aa7..3f9c688d32ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,40 @@
# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
pkgname=gpuvis-git
-pkgver=r859.5b8f4bc
+pkgver=r1639.a138c1cf40c23830d49c
pkgrel=1
pkgdesc=""
arch=(x86_64)
url="https://github.com/mikesart/gpuvis"
license=('MIT')
-source=("git+$url")
-sha1sums=('SKIP')
+source=("git+$url"
+ 'fix.diff')
+sha1sums=('SKIP'
+ '12ad046b5d470ce133e21993498949e48a192553')
pkgver() {
cd "$srcdir"/gpuvis
printf "r%d.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir"/gpuvis
+ patch -sp1 -i "$srcdir"/fix.diff
+}
+
build() {
cd "$srcdir"/gpuvis
+ mkdir build
+ cd build
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ ..
make
}
package() {
cd "$srcdir"/gpuvis
install -dm755 "$pkgdir/usr/bin/"
- install -m755 _release/gpuvis "$pkgdir/usr/bin/"
+ install -m755 build/gpuvis "$pkgdir/usr/bin/"
}
diff --git a/fix.diff b/fix.diff
new file mode 100644
index 000000000000..5ceee424c1d4
--- /dev/null
+++ b/fix.diff
@@ -0,0 +1,58 @@
+diff --git a/Makefile b/Makefile
+index d33da19f0f3c8e3a6d40..eff25631f4fe3764d38f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -29,7 +29,7 @@ VERBOSE ?= 0
+ COMPILER = $(shell $(CC) -v 2>&1 | grep -q "clang version" && echo clang || echo gcc)
+
+ SDL2FLAGS=$(shell sdl2-config --cflags)
+-SDL2LIBS=$(shell sdl2-config --static-libs)
++SDL2LIBS=$(shell sdl2-config --libs)
+
+ ifeq ($(USE_GTK3), 1)
+ GTK3FLAGS=$(shell pkg-config --cflags gtk+-3.0) -DUSE_GTK3
+diff --git a/src/gpuvis_etl.cpp b/src/gpuvis_etl.cpp
+index 549c4f29d6aaa3cad99e..26d1ad9fdea6da5bed72 100644
+--- a/src/gpuvis_etl.cpp
++++ b/src/gpuvis_etl.cpp
+@@ -22,6 +22,18 @@
+ * THE SOFTWARE.
+ */
+
++#include <cstddef>
++#include <cstdlib>
++#include <string>
++#include <unordered_map>
++#include <vector>
++#include <functional>
++
++#define GPUVIS_TRACE_IMPLEMENTATION
++#include "gpuvis_macros.h"
++
++#include "trace-cmd/trace-read.h"
++
+ // Parsing ETL files is only supported on windows
+ // We heavily rely on the TDH windows library for the heavy lifting
+ #ifdef _WIN32
+@@ -1001,7 +1009,7 @@ int read_etl_file( const char *file, StrPool &strpool, trace_info_t &trace_info,
+ // Stub implementation for non-windows OSs
+ int read_etl_file( const char *file, StrPool &strpool, trace_info_t &trace_info, EventCallback &cb )
+ {
+- return -1
++ return -1;
+ }
+ #endif
+
+diff --git a/src/gpuvis_macros.h b/src/gpuvis_macros.h
+index 8efa70e19f7e68906832..416acc8a53a755412d9e 100644
+--- a/src/gpuvis_macros.h
++++ b/src/gpuvis_macros.h
+@@ -24,6 +24,8 @@
+ #ifndef GPUVIS_MACROS_H_
+ #define GPUVIS_MACROS_H_
+
++#include <string.h>
++
+ // Disable gpuvis ftrace tracing by default
+ #define GPUVIS_TRACE_UTILS_DISABLE
+ #include "../sample/gpuvis_trace_utils.h"