summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2016-05-22 18:26:42 -0700
committerShadowKyogre2016-05-22 18:26:42 -0700
commit67b89d10378ca499ded4cfcd4c9cfc2c51e9565f (patch)
tree7e31edd646bce35c39861f0ec094744f7493ef45
downloadaur-67b89d10378ca499ded4cfcd4c9cfc2c51e9565f.tar.gz
First commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore3
-rw-r--r--LICENSE.gpw3
-rw-r--r--PKGBUILD34
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78df4c763305
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Mon May 23 01:26:36 UTC 2016
+pkgbase = gpw
+ pkgdesc = Generate pronouncable passwords
+ pkgver = 1
+ pkgrel = 1
+ url = http://www.multicians.org/thvv/tvvtools.html#gpw
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = words
+ source = ftp://ftp.multicians.org/gpw.C
+ source = ftp://ftp.multicians.org/loadtris.C
+ source = ftp://ftp.multicians.org/gpw.Makefile
+ source = LICENSE.gpw
+ sha256sums = ef7a588f9d2845d3ef5a2e183dbc53aa3dc0ce42d37c7f75c6cf4b4154e6b32b
+ sha256sums = 62cff3cadfa1b5db9adede9a89c0667066891298e66ca975b98eb531cf9290cc
+ sha256sums = a4de0fba1ea3cc06f5657885990bb4d700a1fbeddbb83d195eb4ab8a7245b10e
+ sha256sums = ef28be28bfe05697caccee512518d60d4f775c17b23ace41726bf958635be17f
+
+pkgname = gpw
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2ac9011db5e2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.pkg.tar.gz
diff --git a/LICENSE.gpw b/LICENSE.gpw
new file mode 100644
index 000000000000..1d9d0727c997
--- /dev/null
+++ b/LICENSE.gpw
@@ -0,0 +1,3 @@
+* Share your source with others freely
+* Let Tom Van Vleck know you're using it
+* Give me credit, and all the other pioneers, if you use the data or algorithms
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab42fc2adef4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sapphira Armageddos <shadowkyogre.public@gmail.com>
+pkgname=gpw
+pkgver=1
+pkgrel=1
+pkgdesc="Generate pronouncable passwords"
+arch=('i686' 'x86_64')
+url="http://www.multicians.org/thvv/tvvtools.html#gpw"
+license=('custom')
+makedepends=('words')
+source=("ftp://ftp.multicians.org/gpw.C"
+"ftp://ftp.multicians.org/loadtris.C"
+"ftp://ftp.multicians.org/gpw.Makefile"
+"LICENSE.gpw")
+
+prepare() {
+ cd "$srcdir"
+ # make sure there's no type conversion errors
+ sed -e 's/const short/const int/g' -i loadtris.C
+}
+
+build() {
+ cd "$srcdir"
+ make -f gpw.Makefile
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 gpw "$pkgdir/usr/bin/gpw"
+}
+
+sha256sums=('ef7a588f9d2845d3ef5a2e183dbc53aa3dc0ce42d37c7f75c6cf4b4154e6b32b'
+ '62cff3cadfa1b5db9adede9a89c0667066891298e66ca975b98eb531cf9290cc'
+ 'a4de0fba1ea3cc06f5657885990bb4d700a1fbeddbb83d195eb4ab8a7245b10e'
+ 'ef28be28bfe05697caccee512518d60d4f775c17b23ace41726bf958635be17f')