summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Korotkiy2019-12-11 12:18:15 +0300
committerNikolay Korotkiy2019-12-11 12:18:15 +0300
commitba9b20125f9c62e669e3ae6f8782bf844abd267d (patch)
tree532e1edf7cf3a9599b326791479a8aac5619c925
parent61f96eb1de3da08101bf9a40d8b27e59d2eb2fcf (diff)
downloadaur-ba9b20125f9c62e669e3ae6f8782bf844abd267d.tar.gz
release v0.7.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--fix-quit-shortcut.diff37
3 files changed, 15 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5984fdc950b1..c8816f79cbdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
-# Generated by makepkg 5.1.3
-# Tue Sep 10 08:23:08 UTC 2019
+# Generated by makepkg 5.2.1
+# Wed Dec 11 09:16:07 UTC 2019
pkgbase = gpxlab
pkgdesc = Program to show and manipulate GPS tracks
- pkgver = 0.6.0
- pkgrel = 2
+ pkgver = 0.7.0
+ pkgrel = 1
url = https://github.com/BourgeoisLab/GPXLab
arch = x86_64
license = GPL3
makedepends = qt5-tools
depends = qt5-base
- provides = gpxlab=0.6.0
+ optdepends = qt5-translations: for Qt5 dialog translations
+ provides = gpxlab=0.7.0
conflicts = gpxlab-git
- source = https://github.com/BourgeoisLab/GPXLab/archive/v0.6.0.tar.gz
- source = fix-quit-shortcut.diff
- sha256sums = 9b563dbdec884405c740bca63c57f275f2962ed0d84c3bc5ad8872141a65f7ff
- sha256sums = SKIP
+ source = https://github.com/BourgeoisLab/GPXLab/archive/v0.7.0.tar.gz
+ sha256sums = cb9fbcde4688c388b781c90b7c48a60a76c5d5bed14e5040e55a13a3f810aa0e
pkgname = gpxlab
diff --git a/PKGBUILD b/PKGBUILD
index 38eb166b687f..6635bd7ce52a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,42 +2,30 @@
_orgname=BourgeoisLab
_pkgname=GPXLab
pkgname=${_pkgname,,}
-pkgver=0.6.0
-pkgrel=2
+pkgver=0.7.0
+pkgrel=1
pkgdesc='Program to show and manipulate GPS tracks'
arch=(x86_64)
url='https://github.com/BourgeoisLab/GPXLab'
license=('GPL3')
depends=('qt5-base')
makedepends=('qt5-tools')
+optdepends=('qt5-translations: for Qt5 dialog translations')
provides=("${pkgname}=${pkgver}")
conflicts=(${pkgname}-git)
-source=("https://github.com/${_orgname}/${_pkgname}/archive/v${pkgver}.tar.gz"
- "fix-quit-shortcut.diff")
-sha256sums=('9b563dbdec884405c740bca63c57f275f2962ed0d84c3bc5ad8872141a65f7ff'
- 'SKIP')
-
-prepare() {
- cd ${_pkgname}-${pkgver}
-
- patch -Np1 < ../fix-quit-shortcut.diff
-}
+source=("https://github.com/${_orgname}/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('cb9fbcde4688c388b781c90b7c48a60a76c5d5bed14e5040e55a13a3f810aa0e')
build() {
cd ${_pkgname}-${pkgver}
lrelease GPXLab/GPXLab.pro
- qmake GPXLab.pro
+ qmake PREFIX=/usr GPXLab.pro
make
}
package() {
cd ${_pkgname}-${pkgver}
- install -Dm755 bin/GPXLab ${pkgdir}/usr/bin/${pkgname}
- install -Dm644 GPXLab/locale/*.qm -t ${pkgdir}/usr/share/${pkgname}/translations
- install -Dm644 doc/gpxlab.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
- install -Dm644 pkg/gpxlab.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
- install -Dm644 pkg/gpxlab.xml ${pkgdir}/usr/share/mime/packages/${pkgname}.xml
- install -Dm644 pkg/appdata.xml ${pkgdir}/usr/share/metainfo/${pkgname}.appdata.xml
+ make INSTALL_ROOT="${pkgdir}" install
}
diff --git a/fix-quit-shortcut.diff b/fix-quit-shortcut.diff
deleted file mode 100644
index 3bb34a532deb..000000000000
--- a/fix-quit-shortcut.diff
+++ /dev/null
@@ -1,37 +0,0 @@
---- GPXLab-0.6.0/GPXLab/gpxlab.ui.orig 2019-09-10 11:19:23.098925713 +0300
-+++ GPXLab-0.6.0/GPXLab/gpxlab.ui 2019-09-10 11:19:51.539243525 +0300
-@@ -1205,7 +1205,7 @@
- <string>Exit application</string>
- </property>
- <property name="shortcut">
-- <string>Alt+F4</string>
-+ <string>Ctrl+Q</string>
- </property>
- </action>
- <action name="actionOpen">
---- GPXLab-0.6.0/GPXLab/locale/gpxlab_ru.ts.orig 2019-09-10 11:19:37.115749051 +0300
-+++ GPXLab-0.6.0/GPXLab/locale/gpxlab_ru.ts 2019-09-10 11:20:20.926238290 +0300
-@@ -767,8 +767,8 @@
- </message>
- <message>
- <location filename="../gpxlab.ui" line="1208"/>
-- <source>Alt+F4</source>
-- <translation>Alt+F4</translation>
-+ <source>Ctrl+Q</source>
-+ <translation>Ctrl+Q</translation>
- </message>
- <message>
- <location filename="../gpxlab.ui" line="311"/>
---- GPXLab-0.6.0/GPXLab/locale/gpxlab_fi.ts.orig 2019-09-10 11:19:31.282350525 +0300
-+++ GPXLab-0.6.0/GPXLab/locale/gpxlab_fi.ts 2019-09-10 11:20:08.026094295 +0300
-@@ -767,8 +767,8 @@
- </message>
- <message>
- <location filename="../gpxlab.ui" line="1208"/>
-- <source>Alt+F4</source>
-- <translation>Alt+F4</translation>
-+ <source>Ctrl+Q</source>
-+ <translation>Ctrl+Q</translation>
- </message>
- <message>
- <location filename="../gpxlab.ui" line="311"/>