summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Korotkiy2018-11-08 12:54:19 +0300
committerNikolay Korotkiy2018-11-08 12:54:19 +0300
commit97d0ac46fe37740530ce3b596b3e22db6151de1b (patch)
tree1dcf707eab7c7fb70dca118fe3fc2526a0103ac1
parentcf40f5ac88d610e55675341333e5b9df659a2263 (diff)
downloadaur-97d0ac46fe37740530ce3b596b3e22db6151de1b.tar.gz
Fix prepare()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD23
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a75741e34b1c..8e5a7539b7da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by makepkg 5.1.1
-# Thu Nov 8 08:24:32 UTC 2018
+# Thu Nov 8 09:51:37 UTC 2018
pkgbase = gpxsee-git
pkgdesc = GPS log file viewer and analyzer
pkgver = 6.3.r1280.09242841
diff --git a/PKGBUILD b/PKGBUILD
index 847082cc5f0d..44fe3e68ab82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,7 @@ _pkgname=GPXSee
_branch=master
_use_gh_api=true
wl_project=${_pkgname}
-wl_component=Translations
-wl_dl="https://hosted.weblate.org/download/${wl_project}/${wl_component}"
+wl_dl="https://hosted.weblate.org/download/${wl_project}"
pkgname=${_pkgname,,}-git
pkgver=6.3.r1280.09242841
pkgrel=1
@@ -54,23 +53,27 @@ pkgver() {
printf "%s.r%s.%s" "${release}" "${count}" "${head}"
}
-prepare() {
- cd ${_pkgname}-${_branch}
+wl_update() {
+ find . -name "${2}*.ts" -a ! -name "*template*" | \
+ xargs basename -s .ts | \
+ xargs -P 0 -I{} sh -c "curl -so \$1.ts $wl_dl/${1}/\${1#${2}}/" -- {}
+}
- sed -i "s/\(VERSION = \).*/\1${pkgver}/" gpxsee.pro
+prepare() {
+ cd ${_pkgname}-${_branch}/lang
- rename nb nb_NO lang/gpxsee_nb.ts
+ rename nb nb_NO *_nb.ts
- find lang -name *.ts | \
- xargs basename -s .ts | \
- xargs -P 7 -I{} sh -c "curl -so lang/\$1.ts $wl_dl/\${1#${_pkgname,,}_}/" -- {}
+ wl_update Translations ${_pkgname,,}_
- rename nb_NO nb lang/gpxsee_nb_NO.ts
+ rename nb_NO nb *_nb_NO.ts
}
build() {
cd ${_pkgname}-${_branch}
+ sed -i "s/\(VERSION = \).*/\1${pkgver}/" gpxsee.pro
+
lrelease-qt5 gpxsee.pro
qmake gpxsee.pro
make