summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2015-06-08 14:28:00 -1000
committerGaetan Bisson2015-06-08 14:28:00 -1000
commit146e643e49ebe12df5e973224e7c5686ac3e6e0a (patch)
tree3fed2f61bc307b5c9b30ae3253d4241492db1ed6
downloadaur-146e643e49ebe12df5e973224e7c5686ac3e6e0a.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD34
-rw-r--r--gpxviewer.desktop9
-rw-r--r--gpxviewer.install13
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..606c1a8deaca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gpxviewer
+ pkgdesc = a simple program to visualize a gpx file
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = http://blog.sarine.nl/gpx-viewer/
+ install = gpxviewer.install
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL2
+ makedepends = intltool
+ makedepends = vala
+ depends = gdl
+ depends = libchamplain
+ depends = hicolor-icon-theme
+ conflicts = gpxviewer-bzr
+ source = https://launchpad.net/gpx-viewer/trunk/0.4.0/+download/gpx-viewer-0.4.0.tar.gz
+ source = gpxviewer.desktop
+ md5sums = f019a8fdf27391ca568f022b60d381c6
+ md5sums = 8d5ed2f4f1f26a60d078a77f9fd5f2a3
+
+pkgname = gpxviewer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6784174ba1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: jose <jose1711 [at] gmail (dot) com>
+# Contributor: David Dent <thewinch@gmail.com>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=gpxviewer
+arch=('i686' 'x86_64' 'armv7h')
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="a simple program to visualize a gpx file"
+license=('GPL2')
+url="http://blog.sarine.nl/gpx-viewer/"
+depends=('gdl' 'libchamplain' 'hicolor-icon-theme')
+makedepends=('intltool' 'vala')
+conflicts=('gpxviewer-bzr')
+source=("https://launchpad.net/gpx-viewer/trunk/${pkgver}/+download/gpx-viewer-${pkgver}.tar.gz" 'gpxviewer.desktop')
+install=${pkgname}.install
+md5sums=('f019a8fdf27391ca568f022b60d381c6'
+ '8d5ed2f4f1f26a60d078a77f9fd5f2a3')
+
+build() {
+ cd "${srcdir}/gpx-viewer-${pkgver}"
+ sed -ie 's|desktopdir = $(DESTDIR)/|desktopdir =|' Makefile.in
+
+ ./configure \
+ --prefix=/usr \
+ --enable-database-updates=no
+ make
+}
+
+package() {
+ cd "${srcdir}/gpx-viewer-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 $srcdir/${pkgname}.desktop $pkgdir/usr/share/applications/${pkgname}.desktop
+}
diff --git a/gpxviewer.desktop b/gpxviewer.desktop
new file mode 100644
index 000000000000..71beb4927546
--- /dev/null
+++ b/gpxviewer.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=GPX Viewer
+Comment=Viewer for GPX files
+Exec=gpx-viewer
+Terminal=false
+Type=Application
+Categories=Utility;DataVisualization;
+StartupNotify=true
diff --git a/gpxviewer.install b/gpxviewer.install
new file mode 100644
index 000000000000..44dba270c8cb
--- /dev/null
+++ b/gpxviewer.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -f -t usr/share/icons/hicolor
+ [ -x `which update-mime-database` ] && update-mime-database /usr/share/mime
+ [ -x `which update-desktop-database` ] && update-desktop-database -q
+ /bin/true
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -f -t usr/share/icons/hicolor
+ [ -x `which update-mime-database` ] && update-mime-database /usr/share/mime
+ [ -x `which update-desktop-database` ] && update-desktop-database -q
+ /bin/true
+}