summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Băcîrcea2015-06-16 09:48:32 +0300
committerAdrian Băcîrcea2015-06-16 09:48:32 +0300
commit41c6ed072cc2a7b487f57974601c1caf58fefeca (patch)
tree3d8a5a13ba01b69ec646eddefecabe351a8dc65d
downloadaur-41c6ed072cc2a7b487f57974601c1caf58fefeca.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
-rw-r--r--gqlplus.desktop8
-rw-r--r--gqlplus.pngbin0 -> 3830 bytes
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ccb49457c44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gqlplus
+ pkgdesc = Oracle SQLPlus front-end that provides, history and completion
+ pkgver = 1.15
+ pkgrel = 1
+ url = http://gqlplus.sourceforge.net/
+ arch = x86_64
+ license = GPL
+ makedepends = autoconf
+ makedepends = automake
+ depends = xdg-utils
+ source = http://sourceforge.net/projects/gqlplus/files/gqlplus/1.15/gqlplus-1.15.tar.gz
+ source = gqlplus.desktop
+ source = gqlplus.png
+ md5sums = d60e4768b3c065d52a19658d295e8fe8
+ md5sums = 6c8c81ae7ac03b97850e4e0443562a6c
+ md5sums = 46f2bc2f305d852242aa77918f80eab4
+
+pkgname = gqlplus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76ef449513d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: adytzu2007 <adybac at gmail dot com>
+
+pkgname=gqlplus
+pkgver=1.15
+pkgrel=1
+pkgdesc="Oracle SQLPlus front-end that provides, history and completion"
+url="http://gqlplus.sourceforge.net/"
+license=('GPL')
+arch=('x86_64')
+depends=('xdg-utils')
+makedepends=('autoconf' 'automake')
+source=("http://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgver/${pkgname}-${pkgver}.tar.gz"
+ "$pkgname.desktop"
+ "$pkgname.png")
+md5sums=('d60e4768b3c065d52a19658d295e8fe8'
+ '6c8c81ae7ac03b97850e4e0443562a6c'
+ '46f2bc2f305d852242aa77918f80eab4')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ sed -i 's/\[1\.14\]/\[1\.15\]/g' configure.ac
+
+ automake --add-missing
+ aclocal && autoconf
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc
+
+ make
+}
+
+package() {
+ cd "$srcdir"
+
+ ls
+
+ install -Dm664 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm664 "$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/gqlplus.desktop b/gqlplus.desktop
new file mode 100644
index 000000000000..09c17b46311e
--- /dev/null
+++ b/gqlplus.desktop
@@ -0,0 +1,8 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Version=1.0
+Type=Application
+Terminal=true
+Exec=gqlplus
+Name=GQLPlus
+Icon=gqlplus
diff --git a/gqlplus.png b/gqlplus.png
new file mode 100644
index 000000000000..26eb0ef52434
--- /dev/null
+++ b/gqlplus.png
Binary files differ