summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZezadas2018-11-10 17:39:25 +0000
committerZezadas2018-11-10 17:39:25 +0000
commitb13a614fd19a9dd0e2710e480254a0c91bfb4836 (patch)
treecead0a95bd477d023c8b457477c1ff81d89c14ac
downloadaur-b13a614fd19a9dd0e2710e480254a0c91bfb4836.tar.gz
INITIAL COMMIT
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8f615f5ab38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = gr-binviz-git
+ pkgdesc = A GNU Radio Companion out-of-tree module for visualization of char data types
+ pkgver = v5.10ff87e
+ pkgrel = 1
+ url = https://github.com/CBrunsch/BinViz/tree/master/gr-binviz
+ arch = any
+ license = unknown
+ makedepends = cmake
+ depends = gnuradio
+ depends = libosmocore
+ depends = boost
+ depends = swig
+ depends = cimg
+ provides = gr-binviz
+ source = git+https://github.com/CBrunsch/BinViz.git
+ sha1sums = SKIP
+
+pkgname = gr-binviz-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..261144e43975
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: zezadas <zezadasmoreira at gmail dot com>
+
+pkgname=gr-binviz-git
+pkgver=v5.10ff87e
+pkgrel=1
+pkgdesc="A GNU Radio Companion out-of-tree module for visualization of char data types"
+arch=('any')
+url="https://github.com/CBrunsch/BinViz/tree/master/gr-binviz"
+license=(unknown)
+depends=('gnuradio' 'libosmocore' 'boost' 'swig' 'cimg')
+makedepends=('cmake')
+provides=('gr-binviz')
+source=('git+https://github.com/CBrunsch/BinViz.git')
+sha1sums=('SKIP')
+_gitname=BinViz
+
+pkgver() {
+ cd $_gitname
+ printf "v%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+#prepare() {
+ #patch -p0 -i ../utils_itpp.patch
+#}
+
+build() {
+ cd $_gitname/gr-binviz
+ mkdir -p build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$_gitname"/gr-binviz/build
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et: