summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Nehls2015-09-09 21:56:22 +0200
committerRobin Nehls2015-09-09 21:56:22 +0200
commitdb4c6f629bb679e3f58328d2d4ac73179fed5941 (patch)
treefe6c51719d8d3635ca99aef0f04bb45cee267eae
downloadaur-db4c6f629bb679e3f58328d2d4ac73179fed5941.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e044d827fde
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gr-dect2-git
+ pkgdesc = This project was developed to demonstrate the possibility of real-time DECT voice channel decoding by Gnuradio.
+ pkgver = 3fdfe7c
+ pkgrel = 1
+ url = https://github.com/pavelyazev/gr-dect2
+ arch = any
+ license = unknown
+ makedepends = cmake
+ depends = gnuradio
+ depends = boost
+ depends = swig
+ provides = gr-dect2
+ source = git+https://github.com/pavelyazev/gr-dect2.git
+ sha1sums = SKIP
+
+pkgname = gr-dect2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af7af927e3e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Robin Nehls <aur@manol.is>
+
+pkgname=gr-dect2-git
+pkgver=1f5d71f
+pkgrel=1
+pkgdesc="This project was developed to demonstrate the possibility of real-time DECT voice channel decoding by Gnuradio."
+arch=('any')
+url="https://github.com/pavelyazev/gr-dect2"
+license=(unknown)
+depends=('gnuradio' 'boost' 'swig')
+makedepends=('cmake')
+provides=('gr-dect2')
+source=('git+https://github.com/pavelyazev/gr-dect2.git')
+sha1sums=('SKIP')
+_gitname=gr-dect2
+
+pkgver() {
+ cd $_gitname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd $_gitname
+ mkdir build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd $_gitname
+ cd build
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et: