summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefano Campanella2016-07-16 17:13:03 +0200
committerStefano Campanella2016-07-16 17:13:03 +0200
commitba69bc2d7f904eb158a6da547e93323eeca00b2e (patch)
treea7e419d2b246e25b9b148792506827172a7e0629
downloadaur-ba69bc2d7f904eb158a6da547e93323eeca00b2e.tar.gz
some changes
-rw-r--r--.SRCINFO37
-rw-r--r--GR.sh2
-rw-r--r--PKGBUILD34
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7eca654a462d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+# Generated by mksrcinfo v8
+# Sat Jul 16 15:10:35 UTC 2016
+pkgbase = gr-git
+ pkgdesc = A universal framework for cross-platform visualization applications
+ pkgver = 0.18.0.r67.g058c7a6
+ pkgrel = 1
+ url = https://www.gr-framework.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = libx11
+ depends = libxft
+ depends = libxt
+ depends = python2
+ depends = python2-numpy
+ depends = texlive-core
+ depends = python2-opengl
+ depends = mesa-libgl
+ depends = python2-pyqt4
+ depends = ghostscript
+ depends = libmupdf
+ depends = ffmpeg
+ depends = gtk2
+ depends = wxgtk
+ depends = wxpython
+ depends = glfw
+ depends = zeromq
+ depends = python2-pyzmq
+ provides = gr
+ source = git://github.com/jheinen/gr.git
+ source = GR.sh
+ md5sums = SKIP
+ md5sums = 2d404dcad9da344dde04da439df13034
+
+pkgname = gr-git
+
diff --git a/GR.sh b/GR.sh
new file mode 100644
index 000000000000..ce90b20128ba
--- /dev/null
+++ b/GR.sh
@@ -0,0 +1,2 @@
+# /etc/profile.d/GR.sh
+export PYTHONPATH=${PYTHONPATH}:/usr/lib/python
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8f46c489791
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Stefano Campanella <stefanocampanella1729@gmail.com>
+pkgname=gr-git
+_pkgid=${pkgname%-git}
+pkgver=0.18.0.r67.g058c7a6
+pkgrel=1
+pkgdesc="A universal framework for cross-platform visualization applications"
+arch=('i686' 'x86_64')
+url="https://www.gr-framework.org/"
+license=('GPL')
+depends=('libx11' 'libxft' 'libxt' 'python2' 'python2-numpy' 'texlive-core' 'python2-opengl' 'mesa-libgl' 'python2-pyqt4' 'ghostscript' 'libmupdf' 'ffmpeg' 'gtk2' 'wxgtk' 'wxpython' 'glfw' 'zeromq' 'python2-pyzmq')
+makedepends=('git')
+provides=('gr')
+source=("git://github.com/jheinen/gr.git"
+ "GR.sh")
+md5sums=('SKIP'
+ '2d404dcad9da344dde04da439df13034')
+
+pkgver() {
+ cd $_pkgid
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build(){
+ cd $_pkgid
+ make ${MAKEFLAGS}
+}
+
+package() {
+ cd $_pkgid
+ make GRDIR="${pkgdir}/usr/"
+ make install GRDIR="${pkgdir}/usr/" PYTHONBIN="/usr/bin/python2"
+ install -D "${srcdir}/GR.sh" "${pkgdir}/etc/profile.d/GR.sh"
+ rm ${pkgdir}/usr/bin/anaconda
+}