summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZezadas2017-04-26 17:52:12 +0100
committerZezadas2017-04-26 17:52:12 +0100
commit4a19b61e81ba8c652a8c5f2503fd420bd485c047 (patch)
treeb3088541e79eb06a609968b4dcca87d51c88bdc0
downloadaur-4a19b61e81ba8c652a8c5f2503fd420bd485c047.tar.gz
INITIAL COMMIT
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3fb7d0e032b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gr-ham-git
+ pkgdesc = A collection of GNU Radio blocks useful for amateur radio
+ pkgver = 0ac9253
+ pkgrel = 1
+ url = https://github.com/argilo/gr-ham.git
+ arch = any
+ license = unknown
+ makedepends = cmake
+ depends = gnuradio
+ depends = libosmocore
+ provides = gr-ham
+ source = git://github.com/argilo/gr-ham.git
+ sha1sums = SKIP
+
+pkgname = gr-ham-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a48f75d2a7ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Zezadas <zezadasmoreira@gmail.com>
+
+pkgname=gr-ham-git
+pkgver=0ac9253
+pkgrel=1
+pkgdesc="A collection of GNU Radio blocks useful for amateur radio"
+arch=('any')
+url="https://github.com/argilo/gr-ham.git"
+license=(unknown)
+depends=('gnuradio' 'libosmocore')
+makedepends=('cmake')
+provides=('gr-ham')
+source=('git://github.com/argilo/gr-ham.git')
+sha1sums=('SKIP')
+_gitname=gr-ham
+
+pkgver() {
+ cd $_gitname
+ echo $(git describe --always | sed 's/-/./g')
+}
+
+build() {
+ cd $_gitname
+ mkdir build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd $_gitname
+ cd build
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et: