summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob (Jack/XDjackieXD)2021-02-21 13:15:38 +0100
committerJakob (Jack/XDjackieXD)2021-02-21 13:15:38 +0100
commit18713ec9f069ef1f6107c86dbefcbd05a92260ca (patch)
tree836a1a59447df670b26978fb68ace4737bb0d437
downloadaur-18713ec9f069ef1f6107c86dbefcbd05a92260ca.tar.gz
Initial upload of gr-satnogs-git
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD39
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e6e1688fa47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = gr-satnogs-git
+ pkgdesc = gr-satnogs from librespacefoundation
+ pkgver = r584.1103a05
+ pkgrel = 1
+ url = https://gitlab.com/librespacefoundation/satnogs/gr-satnogs.git
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = swig
+ depends = gnuradio
+ depends = gr-soapy
+ depends = png++
+ depends = nlohmann-json
+ depends = libvorbis
+ depends = libogg
+ depends = libvolk
+ depends = libpng
+ provides = gr-satnogs
+ conflicts = gr-satnogs
+ source = git+https://gitlab.com/librespacefoundation/satnogs/gr-satnogs.git
+ sha256sums = SKIP
+
+pkgname = gr-satnogs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dbb5a8767f5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jakob (XDjackieXD) <aur at chaosfield dot at>
+
+pkgname=gr-satnogs-git
+pkgver=r584.1103a05
+pkgrel=1
+pkgdesc="gr-satnogs from librespacefoundation"
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/librespacefoundation/satnogs/gr-satnogs.git"
+license=('GPL3')
+depends=('gnuradio' 'gr-soapy' 'png++' 'nlohmann-json' 'libvorbis' 'libogg' 'libvolk' 'libpng')
+makedepends=('git' 'cmake' 'swig')
+provides=('gr-satnogs')
+conflicts=('gr-satnogs')
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd gr-satnogs
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ mkdir -p gr-satnogs/build
+ cd gr-satnogs/build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make
+}
+
+package() {
+ cd gr-satnogs/build
+
+ make DESTDIR="$pkgdir" install
+}
+