summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Vikstrom2018-09-16 11:19:10 +0200
committerSimon Vikstrom2018-09-16 11:19:10 +0200
commit727f5bc4e815caf6b57236186478b455a73674aa (patch)
tree49d9b83a5c70a8bade752cb3793e6c766df5417c
downloadaur-727f5bc4e815caf6b57236186478b455a73674aa.tar.gz
First commit, heavly based on gr-satelites
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0939e7005058
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gr-soapy-git
+ pkgdesc = gr-soapy from librespacefoundation
+ pkgver = r26.946f950
+ pkgrel = 1
+ url = https://gitlab.com/librespacefoundation/gr-soapy.git
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = swig
+ depends = gnuradio
+ depends = boost
+ provides = gr-soapy
+ conflicts = gr-soapy
+ source = git+https://gitlab.com/librespacefoundation/gr-soapy.git
+ sha256sums = SKIP
+
+pkgname = gr-soapy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..660c79bfd294
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Simon Vikstrom <simon@devsn.se>
+
+pkgname=gr-soapy-git
+pkgver=r26.946f950
+pkgrel=1
+pkgdesc="gr-soapy from librespacefoundation"
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/librespacefoundation/gr-soapy.git"
+license=('GPL3')
+depends=('gnuradio' 'boost')
+makedepends=('git' 'cmake' 'swig')
+provides=('gr-soapy')
+conflicts=('gr-soapy')
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd gr-soapy
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ sed -i 's/env python$/env python2/g' gr-soapy/python/*
+
+ mkdir -p gr-soapy/build
+ cd gr-soapy/build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make
+}
+
+package() {
+ cd gr-soapy/build
+
+ make DESTDIR="$pkgdir" install
+}